ASSERTION: Bookmark hash table out-of-sync with the database

RESOLVED DUPLICATE of bug 378820

Status

()

--
major
RESOLVED DUPLICATE of bug 378820
12 years ago
9 years ago

People

(Reporter: bzbarsky, Assigned: dietrich)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
BUILD:  Current trunk build with or without --enable-places-bookmarks

STEPS TO REPRODUCE:  Start the build

EXPECTED RESULTS: No assertions

ACTUAL RESULTS:  

###!!! ASSERTION: Bookmark hash table out-of-sync with the database: 'realBookmarked == *aBookmarked', file ../../../../../mozilla/toolkit/components/places/src/nsNavBookmarks.cpp, line 2009

(gdb) p realBookmarked 
$1 = 0
(gdb) p *aBookmarked 
$2 = 1
#0  0xb357c382 in nsNavBookmarks::IsBookmarked (this=0x86da4e8, aURI=0x8b44e68, 
    aBookmarked=0xbfffe8ec)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavBookmarks.cpp:2008
#1  0xb357f6a9 in nsNavBookmarks::OnVisit (this=0x86da4e8, aURI=0x8b44e68, aVisitID=458, 
    aTime=1177874539484792, aSessionID=519, aReferringID=0, aTransitionType=0)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavBookmarks.cpp:2540
#2  0xb3540cdd in nsNavHistory::AddVisit (this=0x86fca20, aURI=0x8b44e68, 
    aTime=1177874539484792, aReferringVisit=0, aTransitionType=0, aIsRedirect=0, 
    aSessionID=519, aVisitID=0xbfffebb0)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavHistory.cpp:1840
#3  0xb35451c5 in nsNavHistory::AddVisitChain (this=0x86fca20, aURI=0x8b44e68, 
    aTime=1177874536440260, aToplevel=1, aIsRedirect=0, aReferrer=0x0, 
    aVisitID=0xbfffebb0, aSessionID=0xbfffeba8, aRedirectBookmark=0xbfffebb8)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavHistory.cpp:2859
#4  0xb3544cd4 in nsNavHistory::AddURIInternal (this=0x86fca20, aURI=0x8b44e68, 
    aTime=1177874536440260, aRedirect=0, aToplevel=1, aReferrer=0x0)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavHistory.cpp:2729
#5  0xb3546083 in nsNavHistory::CommitLazyMessages (this=0x86fca20)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavHistory.cpp:3164
#6  0xb3545f96 in nsNavHistory::LazyTimerCallback (aTimer=0x8b44f88, aClosure=0x86fca20)
    at ../../../../../mozilla/toolkit/components/places/src/nsNavHistory.cpp:3150
#7  0xb7de3816 in nsTimerImpl::Fire (this=0x8b44f88)
    at ../../../mozilla/xpcom/threads/nsTimerImpl.cpp:383
#8  0xb7de39c3 in nsTimerEvent::Run (this=0xb4044fb0)
    at ../../../mozilla/xpcom/threads/nsTimerImpl.cpp:456
(Assignee)

Comment 1

12 years ago
this looks like a dupe of bug 378820. i'll check that in today.

actually, that call to the bookmarks service should probably be ifdef'd out for non-places-bookmarks builds, so let's keep this open for making that happen.
Assignee: nobody → dietrich
(Assignee)

Comment 2

12 years ago
just checked bug 378820 in; can you please check if you still get this assertion?
(Assignee)

Comment 3

12 years ago
Created attachment 263370 [details] [diff] [review]
don't set up observer if not MOZ_PLACES_BOOKMARKS
Attachment #263370 - Flags: review?(sspitzer)
Comment on attachment 263370 [details] [diff] [review]
don't set up observer if not MOZ_PLACES_BOOKMARKS

r=sspitzer

but, a question:  

according to cvs blame, the call to AddObserver() was moved from the top of ::Init() to the bottom, see bug #319910.

do we need the call to AddObserver() somewhere else in ::Init() for non-places?

does anything braek for non-places if we don't have this observer?
Attachment #263370 - Flags: review?(sspitzer) → review+
(Reporter)

Comment 5

12 years ago
Yeah, I'm no longer getting this assert, in either places or non-places builds.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378820
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.