Javascript doesn't detect page load, causing the "map loading" message to remain visible forever

RESOLVED INVALID

Status

()

Core
DOM
RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: Jarrard, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

This is a active javascript map, I do not know why this happens but it happens in firefox as well as seamonkey, does not occur in any other browsers (even opera works) so I suspect there is a nasty bug in mozilla. This problem is VERY obvious, just goto the URL load the map and witness, surely a fix can be made !?!

Reproducible: Always

Steps to Reproduce:
1.just load page, the loading map animation will never leave!
2.
3.
Actual Results:  
Load URL!

Expected Results:  
Clear view of map without loading map popup

load map.

Comment 1

11 years ago
Confirming in Firefox 2.0.0.3. It appears that we have a DOM bug that prevents the script from kicking in when the page is loaded. Gran Paradiso Alpha 4 test needed.
Assignee: general → general
Status: UNCONFIRMED → NEW
Component: General → DOM
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch

Updated

11 years ago
Summary: Javascript map loading will not go away, ONLY mozilla browsers have this issue!! → Javascript doesn't detect page load, causing the "map loading" message to remain visible forever

Comment 2

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070427 Minefield/3.0a4pre

Happens on a current trunk build, too. I looked into this briefly and it looks like there is a function called "hideRetrieveMap" that's called to hide that <div>. It's called a bunch of places in the aimsXML.js script, but I'm not sure where/why it's failing.
OS: Windows Vista → All
Version: 1.8 Branch → Trunk
In general, you should not confirm bugs, unless it is very clear that it is a bug in Mozilla. Although there is indeed a good chance this is a bug in Mozilla, it can still be a  site issue.

Switching the user agent string in Mozilla to Opera or IE6, doesn't help.
Keywords: qawanted
I mailed the webmasters of that page, I'm hoping they might help find out what is causing this.
Assignee: general → nobody
QA Contact: ian → general

Comment 5

4 years ago
This issue is still reproducing on Firefox 28.0a1 (Ubuntu 13.04 32bit). When I click the ongoing loading animation, I get the following message:
"Form for posting request not found. Unable to communicate with server."

I think this is a site issue though, since it reproduces on other browsers too (Chrome on Ubuntu 13.04, IE 11 on Win 7 64bit).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.