If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

up/down or page up/down do not work when firefox first launched.

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Steve H, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When firefox is first launched the up/down arrow keys or page up/down keys do not move the web page accordingly.  This problem disappears after opening up another tab. Noticed most often when starting up and going straight into ebay.  I normally click somewhere on the page I want to scroll (not on a web link) then press the appropriate arrow or Page up/down keys.

Reproducible: Always

Steps to Reproduce:
1. Launch firefox.
2. Goto www.ebay.co.uk
3. Press up, down, page-up or page-down.  Nothing happens.
4. Open another tab.
5. Return to the tab showing ebay.
6. Up, down, page-up and page-down keys now work.
Actual Results:  
Arrow or page-up/down keys did not scroll the web page until another tab was opened (and optionally closed).

Expected Results:  
Up, down, page-up or page-down keys should scroll the active page accordingly.

Comment 1

11 years ago
works for me - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070428 Minefield/3.0a5pre ID:2007042804
Also wfm on  Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.4pre) Gecko/2007043003 BonEcho/2.0.0.4pre

This is maybe a dupe of Bug 374881
And WFM as well using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3)
Gecko/20070309 Firefox/2.0.0.3

Steve, can you reproduce with a new profile?
(Reporter)

Comment 4

11 years ago
Created a new windows user account as suggested, launched firefox, keyed in www.ebay.co.uk and the up/down arrow keys worked.  Bookmarked ebay, closed then re-launched firefox and went to ebay via the bookmark. This time the up/down arrow keys did not work.  So to reproduce, amend step 2 to read "select bookmark for http://www.ebay.co.uk
Steve, I used the following steps and could not reproduce this:

STR:
 1. Open Firefox
 2. Go to www.ebay.co.uk
 3. Bookmark the page into the bookmark toolbar
 3a. Go to google.com (only necessary if you have session saving on)
 4. Quit Firefox
 5. Open Firefox
 6. Click the bookmark in the toolbar you create in #3 above

Using those steps, I *cannot* reproduce.

Can you reproduce if you create a new profile and only modify it with the added bookmark using the steps above?

http://kb.mozillazine.org/Profile_Manager
(Reporter)

Comment 6

11 years ago
Tried the above steps and the up/down keys did not work.  I tested the same process on two other laptops running windows xp and firefox 2.0.0.1.  On both of these machines the keys worked.  After I upgraded one machine (identical setup to the one I'm using) to firefox 2.0.0.3 the up/down keys failed when following those steps.

Comment 7

11 years ago
On the computer that you are having this problem on open up Firefox and press the f7 key. This will turn on/off Firefox's caret browsing. http://kb.mozillazine.org/Accessibility.browsewithcaret#Background
(Reporter)

Comment 8

11 years ago
I wasn't aware of pressing f7.  Anyway it was switched off.  Switching it on allowed the ebay web page to scroll.  Doing a little more testing and found the following (on the computer with the problem – firefox 2.0.0.3).

1. Launch firefox (default home page is google.co.uk).
2. Select ebay.co.uk bookmark (up/down keys do not work).
3. Press f7
4. Click on No when asked to turn on caret browsing.
5. Up/Down arrow keys now work.
so this is WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.