Closed Bug 379353 Opened 15 years ago Closed 14 years ago

[FIX]When inserting table caption part of old table remains (doesn't repaint)

Categories

(Core :: Layout: Tables, defect, P2)

x86
All
defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta2

People

(Reporter: wildmyron, Assigned: bzbarsky)

References

Details

(Keywords: testcase, Whiteboard: [dbaron-1.9:RwCr])

Attachments

(2 files)

Attached file Testcase
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre ID:2007050101 [cairo]

Tested on WinXP and Linux

Slightly modified testcase from bug 368335. Inserting the caption shifts the table down, but part of the old table is left behind.

Not sure exactly what is going on here but behaviour is only present since bug 363248 landed. Admittedly, nothing happens with trunk versions up to at least 3 months prior to the fix.
Didn't you paste the wrong bug number (Bug 379229) as blocking? 
(In reply to comment #1)
> Didn't you paste the wrong bug number (Bug 379229) as blocking? 

Aargh, you're right. I must've been staring at that testcase for too long.

Sorry for the bugspam.



Blocks: 379229
No longer blocks: 363248
Confirmed on Mac trunk (debug build).
Keywords: testcase
Flags: blocking1.9?
Summary: When inserting table caption part of old table remains → When inserting table caption part of old table remains (doesn't repaint)
Flags: blocking1.9? → blocking1.9+
Whiteboard: [dbaron-1.9:RwCr]
Attached patch FixSplinter Review
Simple fix.  Just follow the contract and all.
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #286526 - Flags: superreview?(roc)
Attachment #286526 - Flags: review?(roc)
Priority: -- → P2
Summary: When inserting table caption part of old table remains (doesn't repaint) → [FIX]When inserting table caption part of old table remains (doesn't repaint)
Target Milestone: --- → mozilla1.9 M10
Comment on attachment 286526 [details] [diff] [review]
Fix

yes thats it
Attachment #286526 - Flags: review?(roc) → review+
Attachment #286526 - Flags: superreview?(roc) → superreview+
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Verified fixed on Windows

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007110805 Minefield/3.0b2pre ID:2007110805

Thanks everyone.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.