Java Script works for me but not for boss?

RESOLVED DUPLICATE of bug 243170

Status

defect
RESOLVED DUPLICATE of bug 243170
12 years ago
3 years ago

People

(Reporter: michelle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Unknown

Here is the screen shot.  The pop up message works as intended but then the error console pops up: 


Reproducible: Always

Steps to Reproduce:
1.click on link
2.pop up message appears
3.Error console appears
Actual Results:  
Error console appears with the following:
Datasource: Addon Update Started: talkback@mozilla.org
Datasource: Addon Update Ended: talkback@mozilla.org, status: 32
Datasource:  Addon Update Started: (972ce4c6-7e08-4474-a285-3208198ce6fd)
Datasource: Addon Update Ended: (972ce4c6-7e08-4474-a205-3208198ce6fd), Status 32
Datasource: Update Ended
(now starts the error)
Unknown property 'filter'. Declaration dropped.
http://www.aolcdn.com/_media/aolp_v21/main.css
Unknown property 'filter'. declaration dropped.
http://www.aolcdn.com/_media/aolp_v21/main.css
Error in parsing value for property 'cursor'. declaration dropped.
http://www.aolcdn.com/_media/aolp_v21/main.css
and it goes on

Expected Results:  
Simple error type pop up message.  Hard for me to test alternative solutions since my computer does not have the same software.  

web page designed with simple java scripted error pop up message.  Here is the actual script:
In Header:
function MM_popupMsg(msg) { //v1.0
  alert(msg);

onclick="MM_popupMsg('UNIT: A Unit means any real property or structure, or part thereof, situated in the United States with a PB Plumbing System or PB Yard Service Line. A Type I Unit is a single etc...don't need to bore you with all of it.')" 
              href="javascript:">dwelling or other unit</A> plumbed with a <A

Actual link: www.mckeephotoandwebdesign.com/atlantis/guidelines.htm

It's hard for me to test any alternative solutions since this coding performs correctly for me.  The other individual just got new computers & I'm wondering if this has something to do with it and he needs to update his software. 

I do have a screen shot of the error console if that would help my client.

Comment 1

12 years ago
The problem is: href="javascript:"  I don't think that's necessary.  

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243170
Reporter

Comment 2

12 years ago
Yes, that is neccessary---as far as I can tell.  I take it out and there goes the java link.....

Comment 3

12 years ago
I assume you mean the anchor is not styled like a hyperlink which is normally blue colored underlined text and instead looks like normal text.  To retain the styling try this:

<a href="javascript:MM_popupMsg('UNIT: .....etc.')">

In this case the onclick handler isn't used.  By default anchors only get the hyperlink styling when they have a href attribute.  

Or you could use the onlick handler and do the styling manually.  
Reporter

Comment 4

12 years ago
OK, that worked for me.  Hopefully it works for my client...thank you!!!!!
Reporter

Comment 5

12 years ago
Still creating issues for my client....here's the coding I have now:

href=javascript: onclick="MM_popupMsg('PB PLUMBING SYSTEM: That portion of any potable water distribution system with an Installation Date between January 1, 1978 and July 31, 1995, which is within a structure and is composed of Polybutylene Pipe with acetal or metal insert fittings (or any combination thereof). PB Plumbing System does not include PB Yard Service Line.')" 
              >Polybutylene (PB) Plumbing System</A>

Still opening the control panel.......I'm lost.

Comment 6

12 years ago
onclick= should not be there.  
<a href="javascript:MM_popupMsg('...
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.