Closed Bug 379407 Opened 13 years ago Closed 13 years ago

FF3: Frame not extended vertically when closing all but one tab which contains frames page

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 363707

People

(Reporter: thomasverelst, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre

Consider having several tabs open and one of them contains a page with frames, preferably with a colored background so the problem can be demonstrated more clearly.  "Always show the tab bar" should be unchecked.

Close all tabs except the page with frames.

The tab bar disappears and the web page shifts upwards, leaving a white gap at the bottom the height of a tab bar were it still present.

Reproducible: Always
For a testcase, follow this link:
http://users.telenet.be/tc76/Bugzilla/MB379407.html

Open it in a new tab then close all other tabs.

For some reason, it seems as though the page *is* properly redrawn if it was in the first tab.
Summary: FF3: Web page not repainted when closing all but one tab which contains frames page → FF3: Viewport not extended when closing all but one tab which contains frames page
I just noticed that it's not an issue with repainting the web page but with redrawing the viewport.  I updated the above testcase so it displays a vertical scrollbar.  That should make it clearer.
Scratch that.  Upon further investigation, it seems that the problem is that the frame inside the frameset is not enlarged vertically.

If you right-click inside the empty space you actually get a context menu (though it's completely misaligned).  Selecting This Frame > View Source doesn't do anything.

So it looks like the frameset is redrawn, but not the frame element within it.
Summary: FF3: Viewport not extended when closing all but one tab which contains frames page → FF3: Frame not extended vertically when closing all but one tab which contains frames page
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Works (no white gap):
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a1

Broken (white gap):
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1

Due to bug 300030 (reflow branch landing)
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070502 Minefield/3.0a5pre ID:2007050204 [cairo]

1. New profile, start firefox (Pref to hide tabbar when only one tab is true)
2. Load attachment from comment 6 in a new tab
3. Close other tabs

There is a white gap at the bottom of the screen when the tabbar is removed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363707
You need to log in before you can comment on or make changes to this bug.