Table cells with width="100%" are not correctly rendered when another table is in the table this cell belongs to

RESOLVED WORKSFORME

Status

()

Core
Layout
--
trivial
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Julien Moorrees, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre

The following HTML code does not renders the table row correctly:
<table>
  <tr> 
    <td width="21"><img src="/bottom1.gif" alt="" height="17" width="21"></td>
    <td style="background-image: url(/bottom3.gif);" width="100%">&nbsp;</td>
    <td width="22"><img src="/bottom2.gif" alt="" height="17" width="21"></td>
  </tr>
</table>

See the top and low lines of http://forumnl.merudi.net/cgi-bin/ultimatebb.cgi to see the error.

There is a big space between the 1st and 2nd cell. And although the second cell should be 100% in width, it only covers about 50% of the page and then the 3rd cell is already shown directly afterwards it. 

Reproducible: Always

Steps to Reproduce:
Open http://forumnl.merudi.net/cgi-bin/ultimatebb.cgi to see the error in action.



This is the latest trunk version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre

Comment 1

11 years ago
There seems to be more to it than just that code snippet.  That renders ok when in a page by itself.  .  
(Reporter)

Comment 2

11 years ago
You are right, I've reduced it to when it is still shown. It has got something todo when a table is inside. I'll also atach an example that shows this error. The HTML Code that will show this is as follows:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta http-equiv="Content-Type"
 content="text/html; charset=ISO-8859-1">
  <title>Het Levens Forum</title>
  <meta http-equiv="Pragma" content="no-cache">
  <link rel="shortcut icon"
 href="http://forumnl.merudi.net/favicon.ico">

</head>
<body alink="#663f22" bgcolor="#a87d72" link="#663f22"
 text="#000002" vlink="#663f22">
<table align="center" border="0" cellpadding="0"
 cellspacing="0" width="92%">
  <tbody>
    <tr>
      <td width="21"><img src="top1.gif" alt=""
 height="17" width="21"></td>
      <td style="background-image: url(http://forumnl.merudi.net/top3.gif);"
 width="100%">&nbsp;</td>
      <td width="22"><img src="top2.gif" alt=""
 height="17" width="21"></td>
    </tr>
    <tr align="center" valign="top">
      <td colspan="3" >
      <table align="center" border="0" cellpadding="0"
 cellspacing="1" width="95%">
        <tbody>
          <tr bgcolor="#000000">
            <td>
            <table border="0" cellpadding="4"
 cellspacing="1" width="100%">
              <tbody>
                <tr bgcolor="#986d62">
                  <td>&nbsp;</td>
                  <td valign="bottom">
                  <b>Forum</b>
                  </td>
                  <td align="center" valign="bottom">
                  <b>Onderwerpen</b>
                  </td>
                  <td align="center" valign="bottom">
                  <b>Berichten</b>
                  </td>
                  <td align="left" nowrap="nowrap"
 valign="bottom">
                  <b>Laatste
Reactie</b>
                  </td>
                  <td align="center" valign="bottom">
                  <b>Moderators</b>
                  </td>
                </tr>
              </tbody>
            </table>
            </td>
          </tr>
        </tbody>
      </table>
      </td>
    </tr>
    <tr>
      <td width="21"><img src="bottom1.gif"
 alt="" height="17" width="21"></td>
      <td style="background-image: url(http://forumnl.merudi.net/bottom3.gif);"
 width="100%">&nbsp;</td>
      <td width="22"><img src="bottom2.gif"
 alt="" height="17" width="21"></td>
    </tr>
  </tbody>
</table>
</body>
</html>
(Reporter)

Comment 3

11 years ago
Created attachment 263463 [details]
Problem display

This shows the problem. The top and bottom bar should have a width of 100%. There goes something wrong with the rendering when a table is inside the cel.
(Reporter)

Updated

11 years ago
Summary: Table cells with width="100%" are not correctly rendered → Table cells with width="100%" are not correctly rendered when another table is in the table this cell belongs to
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
This is a regression from Bug 300030.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
(Reporter)

Comment 5

11 years ago
Ria, can you explain what your comment exactly means?
I meant that this bug is caused by the fix of Bug 300030 (like a lot of bugs). In the field "Depends on" in that bug you can see them all. 
(Reporter)

Comment 7

11 years ago
Ah thanks a lot for this explanation. But if why is 300030 marked as fixed then? It seems to cause a lot of problems :S.
(In reply to comment #7)
Because a fix was checked in.

(Reporter)

Comment 9

11 years ago
(In reply to comment #8)
> Because a fix was checked in.
> 

Well since the fix for bug 300030 clearly doesn't seem to cause a lot of problems, shouldn't this one be re-opened than? 
(Reporter)

Comment 10

11 years ago
BTW, how do you know the fix for bug 300030 causes this problem? Looking at the description of that bug and comments, I can't see how it does.
(Reporter)

Comment 11

11 years ago
Hm, the fix for 300030 doesn't fix the problem. It still exists here.

Comment 12

10 years ago
If there was a regression from bug 300030, it was fixed before release.
The testcase works identically in Fx2 and higher.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.