Lightning replies to Outlook 2003 invites are not taken into account in Outlook

VERIFIED DUPLICATE of bug 377761

Status

Calendar
Import and Export
--
major
VERIFIED DUPLICATE of bug 377761
11 years ago
11 years ago

People

(Reporter: yannack, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 05.pre 2007050204

An Outlook 2003 user sent me an invite to an event. I received it, accepted it in Lightning. Here is the .ics of the invite (emails changed, user.1 is outlook, i am user.2):
BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft CDO for Microsoft Exchange
VERSION:2.0
BEGIN:VTIMEZONE
TZID:(GMT+01.00) Sarajevo/Warsaw/Zagreb
X-MICROSOFT-CDO-TZID:2
BEGIN:STANDARD
DTSTART:16010101T030000
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=10;BYDAY=-1SU
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T020000
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
DTSTAMP:20070502T123607Z
DTSTART;TZID="(GMT+01.00) Sarajevo/Warsaw/Zagreb":20070502T210000
SUMMARY:Debat 2.0
UID:040000008200E00074C5B7101A82E0080000000080FD4538C78CC701000000000000000
 01000000099BA17771C15F247A32344229D48CEBC
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN="USER 2":MAILTO:user.2@provider.fr
ORGANIZER;CN="USER 1":MAILTO:user.1@provider.fr
LOCATION:
DTEND;TZID="(GMT+01.00) Sarajevo/Warsaw/Zagreb":20070502T230000
DESCRIPTION:Plateau de TF1-France 2 :)\N
SEQUENCE:0
PRIORITY:5
CLASS:
CREATED:20070502T123613Z
LAST-MODIFIED:20070502T123613Z
STATUS:CONFIRMED
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-OWNERAPPTID:-2122164265
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE:20070502T123607Z
X-MICROSOFT-CDO-OWNER-CRITICAL-CHANGE:20070502T123607Z
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT00H15M00S
END:VALARM
END:VEVENT
END:VCALENDAR

The Outlook user receives the reply but it is not processed properly. When he checks the event on his calendar, it says no one has accepted or declined the invitation. When he opens my reply email, the properties of the attached .ics are not parsed, instead it simply appears as a regular attachment. If he double clicks on the .ics attachment, the properties of the meeting are displayed with a message saying "Oui, USER 2 participera. Ce message n'a pas été envoyé" which translates to "Yes, USER 2 will participate. This message hasn't been sent". (this message is in his INBOX)
Here is the content of the .ics of the reply: (i have changed the emails again)

BEGIN:VCALENDAR
PRODID:-//Mozilla Calendar//NONSGML Sunbird//EN
VERSION:2.0
METHOD:REPLY
BEGIN:VTIMEZONE
TZID:(GMT+01.00) Sarajevo/Warsaw/Zagreb
X-MICROSOFT-CDO-TZID:2
BEGIN:STANDARD
DTSTART:16010101T030000
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T020000
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20070502T123613Z
LAST-MODIFIED:20070502T124112Z
DTSTAMP:20070502T124112Z
UID:
 040000008200E00074C5B7101A82E0080000000080FD4538C78CC701000000000000000010
 00000099BA17771C15F247A32344229D48CEBC
SUMMARY:Debat 2.0
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN=USER 1:MAILTO:user.1@provider.fr
ATTENDEE;CN=USER 2;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT:MAILTO:
 user.2@provider.fr
DTSTART;TZID=(GMT+01.00) Sarajevo/Warsaw/Zagreb:20070502T210000
DTEND;TZID=(GMT+01.00) Sarajevo/Warsaw/Zagreb:20070502T230000
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-IMPORTANCE:1
TRANSP:OPAQUE
X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for CLASS 
 property. Removing entire property:
X-MICROSOFT-CDO-OWNERAPPTID:-2122164265
DESCRIPTION:Plateau de TF1-France 2 :)\n
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-OWNER-CRITICAL-CHANGE:20070502T123607Z
SEQUENCE:0
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE:20070502T123607Z
BEGIN:VALARM
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Mozilla Alarm: Debat 2.0
ACTION:DISPLAY
END:VALARM
END:VEVENT
END:VCALENDAR


Reproducible: Always

Steps to Reproduce:
1. Create an event in Outlook
2. Add the email address of Lightning contact and choose to notify by email
3. Receive invite in Lightning, and accept (or decline: both cases have been tested)
4. User in Outlook does not have the correct status of participant in the event (but the message properly states "user John Doe will (not) participate")
Actual Results:  
Outlook user cannot properly view if Lightning user will participate or not
reply .ics is not integrated in outlook calendar

Expected Results:  
Outlook user should be able to see if Lightning user will participate or not

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377761

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.