Custom view filters with default tags like "tags isn't Personal" do not match

NEW
Unassigned

Status

Thunderbird
Mail Window Front End
11 years ago
6 years ago

People

(Reporter: Peter van der Walle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: 20070326

When I create a custom view to exclude certain tags, messages with one of the default tags are still displayed. I can however exclude tags I created.

Reproducible: Always

Steps to Reproduce:
1. Create a custom view: Tags - isn't - Personal
2. Select the created view

Actual Results:  
3. Messages tagged personal are still displayed

Expected Results:  
Messages tagged personal should have been excluded from the view.

Comment 1

11 years ago
WFM on 2.0/linux. 

Did the message have other tags too?
Version: unspecified → 2.0

Comment 2

11 years ago
I could imagine two cases here:
1. a message could have an unmigrated label value
   -> this should go away at the latest when toggling the respective tag
2. the message arrived in this folder _after_ the view was selected, e.g. you're in an inbox 
   -> feature, not a bug

Which version of TB are you using?
Does reapplying the view help?
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)
> WFM on 2.0/linux. 
> 
> Did the message have other tags too?

No, Personal was the only tag.

(In reply to comment #2)
> I could imagine two cases here:
> 1. a message could have an unmigrated label value
>    -> this should go away at the latest when toggling the respective tag

This didn't work. I actually deleted the Personal tag, recreated it and retagged the messages. Still the same problem.

> 2. the message arrived in this folder _after_ the view was selected, e.g.
> you're in an inbox 
>    -> feature, not a bug
This was not the case and reapplying the view doesn't make it disappear.
 
> Which version of TB are you using?
version 2.0.0.0 (20070326)
 

Peter, does this issue still occur in the latest supported 2.0.0.14 / trunk nightlies?
Whiteboard: CLOSEME 2008-06-05
(Reporter)

Comment 5

10 years ago
Hi Gary,

I have recreated the issue following the steps in my original message. TB 2.0.0.14 still shows the excluded messages.

Peter
Keywords: qawanted
Whiteboard: CLOSEME 2008-06-05

Comment 6

10 years ago
Ah, ok i see this now. Confirming on linux/trunk (imap account). Tags "doesn't contain" work as expected though. 
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Component: General → Message Compose Window
Ever confirmed: true
Keywords: qawanted
OS: Windows 2000 → All
QA Contact: general → message-compose
Hardware: PC → All
Summary: Custom view filters do not match default tags → Custom view filters with default tags like "tags isn't Personal" do not match

Updated

10 years ago
Component: Message Compose Window → Mail Window Front End
QA Contact: message-compose → front-end

Updated

7 years ago
Depends on: 577819

Updated

7 years ago
Blocks: 577819
No longer depends on: 577819

Comment 7

7 years ago
bug 577819 comment 4 points out that this problem might be bigger than just default tags, there's something wrong with the tags search UI and/or behaviour.

Comment 8

6 years ago
I can't confirm this bug. It works for me. It seems that it is solved.
You need to log in before you can comment on or make changes to this bug.