"Unread Folders" view keeps folders with all-read messages

RESOLVED DUPLICATE of bug 341266

Status

RESOLVED DUPLICATE of bug 341266
12 years ago
12 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

In the message folder pane, I select "Unread Folders" so I see only folders that have unread mail messages. After reading the new messages, the folder changes to regular font (not bold) but continues to stay displayed in the list of "Unread Folders". 

Reproducible: Always

Steps to Reproduce:
1. In the message folder pane, select "Unread Folders"
2. Read all the messages in a folder from that list
3. 
Actual Results:  
The folder, which now has no unread messages, remains in the list.

Expected Results:  
Once the folder no longer contains unread messages, the folder should disappear from that view. While the last unread message is being read, it's OK for the folder to remain in the list, but if I then select a different folder, the list should be refreshed.

Thunderbird gets it's mail via IMAP if that makes a difference.
(Reporter)

Updated

12 years ago
Summary: "Unread Folders" view keeps folders with all-readmessages → "Unread Folders" view keeps folders with all-read messages

Comment 1

12 years ago
you have to cycle through the folder views to get rid of folders in a view. This is similar to what happens with views in the thread pane.
(Reporter)

Comment 2

12 years ago
Yes, that is a suitable work-around until the code can be fixed/enhanced :-)

I really like the new "unread folders" view... I just think it should auto-update so it doesn't just become a "view all" list again. :-)

The list should refresh periodically without me having to change views and then change views back to the view I wanted in the first place.

Or, perhaps a refresh "button". I tried clicking the current view name thinking it might refresh, that would be acceptable. As it is, I now click the "cycle left/cycle right" buttons. UGH. :-)

(Reporter)

Updated

12 years ago
Version: unspecified → 2.0

Comment 3

12 years ago
I'd suggest this is a duplicate of bug 341266

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341266
You need to log in before you can comment on or make changes to this bug.