Incorrect downgrade from 2.0.0.3 to 2.0.0.2, then later offer to update to 2.0.0.3

RESOLVED DUPLICATE of bug 375710

Status

()

RESOLVED DUPLICATE of bug 375710
12 years ago
10 years ago

People

(Reporter: paul_gregg, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Today my Firefox 2.0.0.3 install opened a software update dialog with "an update is available, Firefox 2.0.0.2" with the normal restart & later options. I believe this means that the background update file was already downloaded (no idea it was partial or full). I clicked on the release notes link & it indeed took me to 2.0.0.2 notes. I checked the about dialog, and it did say 2.0.0.3

The later restart came up with the update start page, and the about dialog says 2.0.0.2.
During start, I did notice a Add-on incompatibility dialog, which said Java Console was no longer compatible, which is weird because I have never installed it & it isn't in the list of Add-on Extensions.
Clicking on Help->Check for Updates... does show a dialog with:

An update for Firefox is available:
Firefox 2.0.0.3
...
[Download & Install Now]

Not sure if this has happened to many users, but I expect most would be very confused with the process, presuming they knew about versioning & remembered which one they were running. Actually that seems unlikely, but from their perspective, they would be getting two consecutive updates in quick succession :-(
Please see Bug 375710 for more information about the downgrade.
Can you post the about string from Firefox here in this Bug (its under help -> about Firefox and should look like this: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4) Gecko/20070501 Firefox/2.0.0.4)

The Java Console issue sounds like Bug 364390
(Reporter)

Comment 2

12 years ago
Hi Carsten, the about string is:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
I'm sure this is a dup of Bug 375710, sorry for the hassle. My bugzilla search didn't show anything open, but resolved caused too big of a list. I should of refined it by including 2.0.0.2.  For some reason I presumed it was an open bug, because it hit me, but given the fix, wouldn't show up till 2.0.0.4 (given the 1.8.1.4 branch landing), doh!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375710
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.