TMP directory is filled by newmsg-NNNN files when "quarantine incoming new messages" is ON, then disk full

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Jansson, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-05-25)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1)
Build Identifier: version 2.0.0.0 (20070326)

After Thunderbird worked fine for a week since I started to use it,I now get this message when fetching mail.(every time)
“Unable to write the email to the mailbox. Make sure the file system allows you write privileges, and you have enough disk space to copy the mailbox”

I found there could be a few reasons but none of them worked for me.(http://kb.mozillazine.org/Unable_to_write_the_email_to_the_mailbox)

I had a look in the TMP folder and saw newmsg-9999 + all previous newmsg-* (10000 files in total) and when I deleted them Thunderbird works fine again.

I now had it working for 30 min or soo and i allready got 49 new newmsg-* files in the TMP folder, soo they are not deleted allthough they are empty.
my path to the TMP folder is "C:\Documents and Settings\"insert my user name"\Local Settings\Temp"

I hope this help you locate the problem, if I forgot anything dont hessitate to email me, Im glad to help. Cheers!



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Antivirus isn't involved? Just a wild quess...
Version: unspecified → 2.0
(Reporter)

Comment 2

11 years ago
I turned symantec AntiVirus off (unloading service) but there is still a new "newmsg-*" file each time I press "get new messages".(no auto protect running)

I also tried to turn "windows defender" off but that did not give any improvement either.

Each time I check for new mail I get a new empty file in the TEMP folder.

Could It somehow depend on my settings in Thunderbird 2 ?
Is there a log to check somewhere? 
Can I turn logging on? 

Comment 3

11 years ago
Did you try turning off TB's option to quarantine incoming new messages?
(Reporter)

Comment 4

11 years ago
If I turn off TB's option to quarantine incoming new messages then the files STOP appearing. :) That change of settings solved my problem!

A BIG 'thank you' to both Magnus Melin and David Bienvenu for the helpful suggestions.
If Thunderbird continues to work as well as now it soon convinced all my colleagues to use Thunderbird 2 too.

Best regards,
Magnus Jansson
Changing summary(add "quarantine incoming new messages" and "newmsg-*") for ease of search.
Summary: Unable to write the email to the mailbox → TMP directory is filled by newmsg-NNNN files when "quarantine incoming new messages" is ON, then disk full

Updated

10 years ago
Assignee: mscott → nobody

Comment 6

9 years ago
 Jansson, can you still reproduce?

xref fixed bugs
bug 292079
bug 362539
Whiteboard: closeme 2009-05-25
-> Incomplete due to lack of information. Please reopen if the issue still occurs in the latest Thunderbird trunk builds giving reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 8

9 years ago
I now use "version 2.0.0.21 (20090302)" and my company now uses "symantec endpoint protection". Further we recently switched from POP to IMAP (bug 292079)
.

So I am not able to test under the same conditions as before, BUT now when I turned "quarantine incoming new messages" ON again, NO new "newmsg-*" file is created so it works for me. :) 
But why I dont know :(. 

Thank you for a great client!

Best Regards,
Jansson
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.