Round-trip bracing change with let that binds nothing

RESOLVED DUPLICATE of bug 356247

Status

()

Core
JavaScript Engine
--
minor
RESOLVED DUPLICATE of bug 356247
11 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
x86
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
js> f = function() { for(y in []) let {} = []; }
function () {
    for (y in [])
        let [] = [];
}

js> eval(uneval(f))
function () {
    for (y in []) {
        let [] = [];
    }
}
(Reporter)

Updated

11 years ago
No longer blocks: 349611
(Reporter)

Updated

11 years ago
Blocks: 349611
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356247
You need to log in before you can comment on or make changes to this bug.