Ctrl+A to select all should not clear current selection first

VERIFIED WORKSFORME

Status

()

Core
Selection
P3
minor
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Blake Ross, Assigned: mjudge)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build ID: 2000050208

Steps to Reproduce:

(1) Load Mozilla
(2) Go to http://www.mozilla.org
(3) Starting at the bold S and ending at the period, highlight the 
entire "Scalable Vector Graphics" paragraph.
(4) Press Ctrl+A

Rather than "adding on" to the current selection as it normally does (and as IE 
5.x and NS 4.x do), the paragraph selection is first cleared, and *then* all 
the text is highlighted -- this is noticeable.

If you can't reproduce this the first time, repeat the above steps a couple 
times - sometimes it seems a little faulty.

It also seems to work with all/most of the paragraphs in the left column of 
mozilla.org
(Reporter)

Comment 1

18 years ago
I take that back ~ NS 4.x also displays this behavior in that it first clears 
the current selection.  This looks a little sloppy.

Comment 2

18 years ago
What's the expected behavior?  IE seems to act as you describe, as well.
(Reporter)

Comment 3

18 years ago
IE does not give the appearance of first erasing the initial selection, then 
again selecting.  Instead, it is a smooth selection - the text that is already 
selected seems to stay selected, while everything else that isn't selected 
becomes selected.  This is seen in IE 5.5

Comment 4

18 years ago
Ahh, so it's just a cosmetic thing.  (Setting severity to minor)
Severity: normal → minor

Updated

18 years ago
Target Milestone: --- → M18

Comment 5

18 years ago
This is fine in build# 2000061408.  Marking as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
I have a feeling it's not (many people don't understand this bug), but I'll 
check when I get back.  I'll also try to get a new testcase/example when I get 
back (the original is no longer valid due to a changing mozilla.org)
Whiteboard: blake
(Reporter)

Comment 7

17 years ago
*SPAM*: Changing the QA contact of all open/resolved Selection bugs from 
elig@netscape.com to BlakeR1234@aol.com.  After the many great years of service 
Eli has given to Mozilla, it's time for him to move on; he has accepted a 
position at Eazel.  We'll be sad to see him go, and I'll do my best to fill his 
spot...
QA Contact: elig → BlakeR1234
(Reporter)

Comment 8

17 years ago
I spoke too soon.  Works perfectly in 2000082008 win98. vrfy
Status: RESOLVED → VERIFIED
Whiteboard: blake
You need to log in before you can comment on or make changes to this bug.