RSS doesn't handle URL's with arguments properly (doesn't show content of URL)

RESOLVED INVALID

Status

MailNews Core
Feed Reader
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Sven Boden, Assigned: Scott MacGregor)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

When I add following RSS feed to Thunderbird:

http://forums.pentaho.org/external.php?type=RSS&forumids=153

I get notified of new posts, but the contents of the url from the RSS feed can't be shown correctly. A resulting URL from the feed is e.g.

http://forums.pentaho.org/showthread.php?t=53228&goto=newpost

which I see in the new topic, but the page doesn't show correctly (it takes the wrong thread which is the :?t" argument), if I launch the URL by clicking on it I get as URL in Firefox:

http://forums.pentaho.org/showthread.php?p=0#post0

So I have a hunch arguments are not properly handled when showing RSS contents. I did set the internet proxy correctly (I see in the "Welcome to Thunderbird" page on starting up TB).

The same feed does work properly in newsfox (add-on to firefox), so the problem is not in the RSS feed itself.

Regards,
Sven Boden

Reproducible: Always

Steps to Reproduce:
1. Add http://forums.pentaho.org/external.php?type=RSS&forumids=153 as RSS feed in TB
2. Try to show the contents of a new item

Strange thing is... sometimes it works on 1 item the first time.

Actual Results:  
Contents of the URL sent in the RSS feed but with changed arguments

Expected Results:  
Contents of the URL sent in the RSS feed

Show the contens of the URL sent in the RSS feed
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
I don't know what is supposed to happen (or not) but thunderbird opens the URL it's given, the site then redirects to the new post url - seems intended since the url has a goto=newpost...  
(Reporter)

Comment 2

11 years ago
That's the problem, if I add the exact same RSS feed in newsfox (the add-on to firefox) I see what I expect to see... the last mail in the specified thread. Since it works in newsfox and not in thunderbird I expected some processing to fail or be missing in Thunderbird.

I've been doing some new checks... some of the URLS in the latest feed work when I directly use them in a browser, others do not. So maybe it's a forum problem after all. It's still strange that newsfox translates all of them correctly.

Thanks,
Sven

Comment 3

11 years ago
Maybe it's doing something with cookies... 

->INVALID, since the problem really seems to be on the server side. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.