'Delete Mail Marked as Junk in Folder' always disabled and other bugs

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Mr. Miyagi, Assigned: Scott MacGregor)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 20070326

Since upgrading to 2.0.0.0, 'Delete Mail Marked as Junk in Folder' (from the Tools menu) is always disabled, even though there's Junk-qualified mail in the InBox folder.

Using IMAP account (Cyrus backend).

The destination Junk Folder wasn't seen as the Junk folder after upgrading to 2.0.0.0. By activating the Tools>Account Settings>'account-name'>Junk Settings>Move new Junk messages option we may select the Junk folder. After 'Ok', the Junk folder is now seen as the actual Junk folder (fire-like icon appearing next to the folder name).

Still 'Delete Mail Marked as Junk in Folder' remains disabled while there are messages in Inbox marked as Junk (fire-like icon). 

Going back to Tools>Account Settings>'account-name'>Junk Settings>Move new Junk messages, and deactivating this option maintains the Junk folder as the Junk folder (fire-like icon remains next to Junk folder name).

'Delete Mail Marked as Junk in Folder' remains disabled. 

Selecting the actual Junk folder containing over 9000 junk messages all messages qualified as Junk: Menu 'Tools'/'Delete Mail Marked as Junk in Folder' remains disabled.

This behaviour occurs on 4 different machines. Variations of Windows 2000, SP3, SP4 and Windows XP.

Moreover, selecting any message in any folder should enable the Delete button, however Delete button remains disabled and hitting 'delete' on the keyboard doesn't delete the message.

Selecting a message and then bringing up the context menu (right mouse button) displays the options:

Open Message in New Window
Reply to Sender Only
Reply to All
Forward
Edit as New
Move to
Copy to
Move Again
Tag Mark
Save as
Print Preview
Print 
Delete Message
Get Selected Messages

All of these options are initially enabled except for:

Move to
Delete Message
Get Selected Messages

Now when I select one of the enabled context menu options leading to a submenu (Copy to, Tag or Mark), the options 'Delete Message' and 'Get Selected Messages' are suddenly enabled, however don't perform any action. The menu disappears as if the selected option is now being executed while the selected action 'Delete Message' isn't performed. Note that when 'Delete Message' and 'Get Selected Messages' are activated that 'Move to' remain deactivated. There's some logic as  apparently only the disabled menu options NOT leading to a submenu are activated when clicking on one of the enabled menu options leading to a submenu, however this is logic within illogic. 

Dragging messages from one folder to another does however work. Aforementioned disabled 'Move to' action in the context menu is thus reachable (a move action that is) by dragging and dropping messages.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Resolution: Downgrade to 1.5.0.x and 'Delete Mail Marked as Junk in Folder' is enabled when applicable and messages can be deleted as well (either by hitting 'Delete' button on the keyboard or using the toolbar button 'Delete' or other delete methods (context menu, main menu). Context menu behaves as expected ('Move to' is enabled and performs the expected action).

Comment 1

11 years ago
For the "Get Selected Messages" enabling bug, see bug 375892. Please keep it one issue per bug.

"Delete Mail Marked as Junk in Folder" seems to work fine for me (doesn't seem to depend on there being junk mails in the folder.) Possibly some extension interfering? Anything in the Error Console?

Comment 2

10 years ago
reporter email address is dead.
closing WFM per comment 1
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.