add bookmark dialog is 0 px tall

RESOLVED DUPLICATE of bug 375629

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 375629
11 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

add bookmark dialog is 0 px tall

screen shot coming.

from my console:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'page is neither HTML nor XML' when calling method: [nsIMicrosumm
aryService::getMicrosummaries]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_ST
RING)"  location: "JS frame :: chrome://browser/content/places/bookmarkPropertie
s.js :: BPP_initNamePicker :: line 561"  data: no]
************************************************************
JavaScript error: , line 0: uncaught exception: [Exception... "Component returne
d failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getF
olderTitle]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS fra
me :: chrome://browser/content/places/bookmarkProperties.js :: BPP__appendFolder
ItemToMenuList :: line 374"  data: no]
Created attachment 263738 [details]
screen shot
here's what's going on:

in BPP__initFolderMenuList() we are looking for the list of recently used folders.  in my case, one of those folder (id == 7) has been deleted.  but the last used annotation appears to still there for that folder

then, when calling BPP__appendFolderItemToMenuList(), we will throw that exception because the call to nsNavBookmarks::GetFolderTitle() will fail with NS_ERROR_INVALID_ARG.

two things to do:

1)  protect against this scenario (for existing users) so that if someone hits it, they don't get the 0x "add bookmarks" dialog.
2)  verify when a folder is deleted we delete the annotation.  (I think we might have a bug on that already?)
Assignee: nobody → sspitzer

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376839
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #2)

> 1)  protect against this scenario (for existing users) so that if someone hits
> it, they don't get the 0x "add bookmarks" dialog.

We're soon moving away from places: uri annotations in this dialog.

Even if we didn't, this bug only applies to --enable-places-bookmarks builds.

> 2)  verify when a folder is deleted we delete the annotation.  (I think we
> might have a bug on that already?)

Bug 375629.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375629
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.