Firefox will not quit when asked to. Must force quit. Happens almost daily. Also hangs up a lot.

RESOLVED DUPLICATE of bug 474980

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED DUPLICATE of bug 474980
11 years ago
9 years ago

People

(Reporter: msd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-05-25)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Firefox will not quit when asked to. Must force quit. Happens almost daily.Also hangs up a lot

Reproducible: Always

Steps to Reproduce:
1.close all tabs and then "quit'
2.
3.
Actual Results:  
Firefox will not quit when asked to. Must force quit. Almost daily.

Expected Results:  
It should quit. It shouldn't hang up

Firefox will not quit when asked to. Must force quit. Happens almost daily.Also hangs up a lot
(Reporter)

Comment 2

11 years ago
I truly appreciate your swift response. I've made changes, and if I have any other problems, I will let you know. 

PS: I DO find the "bug files" guidance pages and procedure quite confusing and way, way too much info to sort through. 

It's helpful now to know of that page you sent me too. For those of us who are not engineers, the simple category of problem and plain few sentences of advice are very helpful.
Reporter, do you still see the problem?
(Reporter)

Comment 4

11 years ago
I do still see the problem, however, after following the suggestions given, it is much improved.
Thanks!

Comment 5

10 years ago
This is still a problem; after browsing for a while the page starts to render incorrectly, like maybe the css is wrong.  Still possible to browse, but cannot quit (apple-Q), must use force quit.

Running standard install:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Comment 6

10 years ago
I also see this every 2-3 days.  Firefox will incorrectly and erratically render pages, failing to load images, CSS or plugins.  Reload will sometimes help, sometimes not.  Firefox will not quit and must be Force Quit.

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Comment 7

10 years ago
This is happening again to me right now.  Is there any additional data that I can provide?
(In reply to comment #7)
> This is happening again to me right now.  Is there any additional data that I
> can provide?

Please try http://support.mozilla.com/en-US/kb/Basic+Troubleshooting

Updated

9 years ago
Blocks: 483013

Comment 9

9 years ago
  Bergur, jered, what results do you get using comment 8?
(msd appears to be gone)
Whiteboard: closeme 2009-05-25

Comment 10

9 years ago
I'm running 3.0.10 now and haven't seen the problem in a while.  The Basic Troubleshooting tips were not helpful because of the unpredictability of the bug -- running without any plugins and extensions at all times was not feasible.  If this happens again there really needs to be a way to dump active state -- would a gdb dump be helpful?

Comment 11

9 years ago
This is a constant problem with 3.0 Pre 3 on an Intel Macbook Pro running 10.5.7

It seems that when I background Shredder or if the screen saver kicks in, I can no longer switch folders, open or view messages and I have to force quit to end the program.  It no longer fetches new mail.

Since I doubt the backgrounding or screen saver has anything to do with it, but time itself, I bet its getting hung on a future email fetch.

Shredder has become useless and I've dropped back to pre 2 for normal use.   Let me know what I can do to help you narrow this problem down.

It happens every time I run it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474980
You need to log in before you can comment on or make changes to this bug.