Addon Update Process Corrupts Data

RESOLVED DUPLICATE of bug 378767

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
RESOLVED DUPLICATE of bug 378767
11 years ago
2 years ago

People

(Reporter: David White, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

I am the author of the ThunderbirdBiff addon. When I try to update it at https://addons.mozilla.org/en-US/thunderbird/addon/3788, the update process is very slow and ultimately seems to fail in a number of ways. See the referenced page to see how the process has corrupted the addon's description. Try as I might (maybe 10 times) to fix this, the update process still leaves it hosed up. I also note that the update process (even when it succeeded for my ThunderPlunger addon) ends with an empty page. There doesn't seem right. The addon's website is a valuable asset. Please don't leave it in its current state. Thanks.

Reproducible: Always

Steps to Reproduce:
1.Login as owner of addon and go to https://addons.mozilla.org/en-US/thunderbird/addon/3788.

2. Choose to edit ThunderbirdBiff addon.

3. Try to change Addon Summary information.

4. Press Update.

5. Either wait a long time and a blank page finally displays. The summary data remains corrupted. Or a message is displayed at once that says "An error occurred trying to save your data."


Expected Results:  
I expect to see an "Update Successful" page and to see the changes saved in a far faster time. I expect to see the data entered displayed on the addon's page.

Updated

11 years ago
Blocks: 379821
No longer blocks: 379821
Component: www.mozilla.org → Developer Pages
OS: Windows 2000 → All
Product: mozilla.org → addons.mozilla.org
QA Contact: www-mozilla-org → developers
Hardware: PC → All
Version: other → 3.0

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378767
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.