Closed Bug 379871 Opened 15 years ago Closed 15 years ago

New Mail Notification popup should show last-new messages, not first-new

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 375717

People

(Reporter: doron, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: 2.0.0.0 (20070326)

It appears as the TB2.0 New Mail Notification popup shows the details of the first four messages that have the "New" indicator. When one is busy with another window/task and does not read new mail for a few minutes (and/or when new messages arrive rapidly), the popup would not show the newly-arriving messages; rather, it would always show the *first* four I haven't yet attended to.

The popup should provide the details of the *last* four messages that have the "New" indicator. This way, whenever a new message arrives, the popup will allow a glance at it.

Using IMAP, in case it makes a difference.

It might have something to do with bug 375717, although I couldn't find a direct connection.

Reproducible: Always

Steps to Reproduce:
1. Not attend to the mail window for a few minutes...
2. Fifth (and on) new mail item arrives
3. Popup pops up
Actual Results:  
The message that has just arrived does not appear in the popup

Expected Results:  
The message that has just arrived should be presented in the popup
Seems like a dupe of bug 375717 to me. Or what's the difference? There too you get the unread messages, not the "new" ones.
Yes, it could be a dupe, that's why I mentioned it in the description. The original description of that bug specifies that the messages displayed are of a different folder. This doesn't happen here, and made me doubt whether it is actually the same problem.
Okay, I'm convinced now that it's a dupe (seen some more variants of this behavior).
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375717
You need to log in before you can comment on or make changes to this bug.