Closed Bug 379892 Opened 13 years ago Closed 13 years ago

Firefox ignores ACCEPT value in FORM elements

Categories

(Firefox :: General, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 377624

People

(Reporter: andrew, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

As per http://www.w3.org/TR/html401/interact/forms.html#edef-FORM
a browser should (OK, "may") use the ACCEPT element value to set the file-type filter for file upload operations (INPUT TYPE=FILE). Firefox has a
file-type selector, but it is fixed as "all types".
Firefox also appears to ignore the ACCEPT-CHARSET element.

(IE appears also to ignore ACCEPT; it has 3 predefined choices "all files",
"images", and "HTML")

Reproducible: Always

Steps to Reproduce:
1. Navigate to above page
2. Click "Browse"

Actual Results:  
Firefox shows a list of all files. The file-type selector cannot be changed.

Expected Results:  
Firefox should show a list of files matching the content-type specified in the FORM element, as determined by local mapping e.g. /etc/mime.types. Firefox should
enable the file-type selector to show the list of accepted types, plus "all files". The first element in the accept list should be selected by default.

A wildcard function would be nice; allow accept="image/*" for instance.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377624
You need to log in before you can comment on or make changes to this bug.