Closed Bug 379906 Opened 13 years ago Closed 13 years ago

###!!! ASSERTION: non-strings must be alone: '(quotes->mOpen.GetUnit() != eCSSUnit_String) == (quotes->mNext == nsnull)', file nsCSSDeclaration.cpp, line 283

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9alpha5

People

(Reporter: mats, Assigned: mats)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

###!!! ASSERTION: non-strings must be alone: '(quotes->mOpen.GetUnit() != eCSSUnit_String) == (quotes->mNext == nsnull)', file nsCSSDeclaration.cpp, line 283

STEPS TO REPRODUCE
1. run mochitest on "tests/layout/style/test/"

I see the assertion when this test runs:
  layout/style/test/test_value_storage.html
and also on a couple of other in this directory.
Attached file Testcase #1
Assignee: nobody → mats.palmgren
Keywords: testcase
Attached patch Patch rev. 1Splinter Review
I think this is the test that was intended...
Attachment #263998 - Flags: superreview?(dbaron)
Attachment #263998 - Flags: review?(dbaron)
Comment on attachment 263998 [details] [diff] [review]
Patch rev. 1

r+sr=dbaron
Attachment #263998 - Flags: superreview?(dbaron)
Attachment #263998 - Flags: superreview+
Attachment #263998 - Flags: review?(dbaron)
Attachment #263998 - Flags: review+
Checked in to trunk at 2007-05-07 23:00 PDT.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha5
You need to log in before you can comment on or make changes to this bug.