no error when connecting to non-existent web server

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Stephen Rasku, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I am using the latest nightly build:

	Mozilla/5.0 (X11; U; Linux 2.2.5-15 i686; en-US; m16) Gecko/20000502 
	build ID:2000050215

and I try and connect to a site that is in DNS but isn't running a webserver  I
will not get an error message saying "cannot connect" or anything like that.  It
just says "Document: Done (xx.yy secs)"

This problem does not occur on the NT version of Mozilla.  The Linux version
should generate an error message like the NT version does.

Comment 1

18 years ago
 I can confirm this with a Linux CVS build from today.
 If you start Mozilla pointed at such a machine/page, the
URL bar remains blank (one of the signs of a bad load), but
no popup alert is shown (although the console logs an error
about loading the page).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Target Milestone: --- → M18
(Reporter)

Comment 2

18 years ago
*** Bug 34210 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
make sure you are running the latest build. my pull from today displays the
message.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Verified fixed.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Summary: No error message generated when connecting to non-existent site on Linux → Proxy: no error when connecting to non-existent web server

Comment 5

17 years ago
whoops. not proxy related...
Summary: Proxy: no error when connecting to non-existent web server → no error when connecting to non-existent web server
You need to log in before you can comment on or make changes to this bug.