unable to send links - error console exception [nsIHandlerService::fillHandlerInfo]

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: jenniec45, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-11-25)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

The send link function suddenly stopped working.  Whether I right click or get it from the File drop down menu, nothing happens.  I am able to send links in Internet Explorer, but not from Firefox.  

Reproducible: Always

Steps to Reproduce:
1.trying to send a page link by right clicking or by choosing "send link"from the file drop down menu.
2.
3.
Actual Results:  
Nothing happens.
Works fine here with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Please retest in Firefox's -safe-mode or with a new profile. If that doesn't help try a reinstallation in a new empty folder.

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 2

12 years ago
Thanks for the suggestions.  I tested in safe mode with no luck, then reinstalled in a new folder, but the problem  still persists:-(

Updated

11 years ago
Duplicate of this bug: 390455

Comment 4

11 years ago
Same experience for me: it does not work in safe mode and re installation, new profile will not fix it either.
It's working fine for any 2.0.0.x build of Firefox on my WinXP box. But I can reproduce this malfunction with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101104 Minefield/3.0a9pre ID:2007101104

The error console shows following entries:

Error: [Exception... "'Component is not available' when calling method: [nsIHandlerService::fillHandlerInfo]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://browser/content/browser.js :: anonymous :: line 4612"  data: no]
Source File: chrome://browser/content/browser.js
Line: 4612

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Programme/Mozilla%20Firefox%20(Trunk)/components/nsContentDispatchChooser.js :: ask :: line 82"  data: no]
Source File: file:///C:/Programme/Mozilla%20Firefox%20(Trunk)/components/nsContentDispatchChooser.js
Line: 82

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Programme/Mozilla%20Firefox%20(Trunk)/components/nsContentDispatchChooser.js :: ask :: line 82"  data: no]

The first one shows that the component nsIHandlerService is not available:
http://lxr.mozilla.org/seamonkey/source/uriloader/exthandler/nsIHandlerService.idl#95
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: General → OS Integration
Ever confirmed: true
Keywords: regression
QA Contact: general → os.integration
Version: unspecified → Trunk
(In reply to comment #5)
> The first one shows that the component nsIHandlerService is not available:

Not quite... that's actually bug 393627.

The other exception would explain the bustage, but I can't reproduce it. Can you try a newer build?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102223 Minefield/3.0a9pre

WFM.
(In reply to comment #6)
> The other exception would explain the bustage, but I can't reproduce it. Can
> you try a newer build?

Ok, build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102304 Minefield/3.0a9pre shows me a dialog where I can choose the application.

Meanwhile I'm also sure that my issue doesn't have to do anything with the reporters one. Jennie can you still see this behavior with Firefox 2.0.0.8? If this function doesn't work please have a look inside the Error Console after setting following preferences (about:config):

javascript.options.showInConsole = true
javascript.options.strict = true

While clicking on 'Send Link...' now, will errors be reported?

Comment 9

11 years ago
I am having the same problem.  When I try to use the "send link" and choose "shortcut to desktop" Mozilla suddenly shuts down and returns me to my home page (Windows XP)with a box giving me the option of reopening the session or beginning a new one.  I do not have this problem with Internet Explorer.  Thank you.

Comment 10

10 years ago
I can't reproduce.
still see the problem?
Summary: unable to send links → unable to send links - error console exception [nsIHandlerService::fillHandlerInfo]

Comment 11

10 years ago
Stewart do you still see problem?
Whiteboard: closeme 2008-11-25

Comment 12

10 years ago
This problem has returned in 3.0.4 release on Windows

Neither File/send link nor R-Click "send link" functions at all

Comment 13

10 years ago
(In reply to comment #12)
> This problem has returned in 3.0.4 release on Windows
> 
> Neither File/send link nor R-Click "send link" functions at all

No different problem and not 3.0.4 specific.  I went back to x.x.3 and problem still exists.
Does your system know what e-mail client to use?

Comment 16

10 years ago
(In reply to comment #14)
> Does your system know what e-mail client to use?

I had thought it did, but I discovered that all mailtos were failing.

After wiping out all the settings for mailto and default mail program and resetting them, all (including 'send link') are functioning properly again.

Thanks for the ideas.

Comment 17

10 years ago
no error on console with FF 3.1, and no response from reporter since comment 8.
=> WFM

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.