spaces.live.com - XML Parsing Error when trying to access a blog hosted by MSN Spaces using Camino or non-Firefox browser

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Arthur, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4pre) Gecko/20070501 Camino/1.1b+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4pre) Gecko/20070501 Camino/1.1b+

This web page does not load in Camino, although it works fine in both Safari and Firefox. Error message follows:
XML Parsing Error: syntax error
Location: http://thecrobe.spaces.live.com/blog/cns!708D4D8E02FC37EA!1174.entry?_c=BlogPart
Line Number 3, Column 49:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
------------------------------------------------^

Reproducible: Always

Steps to Reproduce:
Just try to load this page: http://thecrobe.spaces.live.com/blog/cns!708D4D8E02FC37EA!1174.entry?_c=BlogPart
Actual Results:  
XML Parsing Error: syntax error
Location: http://thecrobe.spaces.live.com/blog/cns!708D4D8E02FC37EA!1174.entry?_c=BlogPart
Line Number 3, Column 49:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
------------------------------------------------^

Expected Results:  
The page should have loaded correctly, as it does on Safari and Firefox.

Comment 1

11 years ago
The server should serve content to Camino correctly, rather than serving it as text/html to Firefox and Safari, but as application/xhtml+xml to any user-agent it doesn't recognize:
  Content-Type: application/xhtml+xml; charset=utf-8

This is a server bug, and should be reported to live.com.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Okay, sorry for believing it was a Camino bug... One more reason to tell my friend (whose blog it is) to get rid of MSN things...

Sorry again for wasting your time. Camino definitely rules.

Updated

11 years ago
Status: RESOLVED → VERIFIED
What seems to be happening is they're assuming all non-Firefox Gecko agents (Camino, Minefield, etc.) are mobile browsers and redirecting you to the mobile.spaces.live.com equivalent for any blog, which is served as application/xhtml+xml, without styles, and sometimes with XML parsing errors.

Based on that info, I'm going to reopen and kick this to TE.
Blocks: 114158, 334967
Status: VERIFIED → UNCONFIRMED
Component: General → English US
Product: Camino → Tech Evangelism
Resolution: INVALID → ---
Summary: XML Parsing Error when trying to access a blog hosted by MSN Spaces → spaces.live.com - XML Parsing Error when trying to access a blog hosted by MSN Spaces using Camino or non-Firefox browser
I haven't ever managed to see the XML parsing error part myself, but smorgan has, as have several people on the forum.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → english-us

Comment 5

11 years ago
This bug is similar to bug 357190, which was eventually fixed by Microsoft.  You might want to follow the instructions at https://bugzilla.mozilla.org/show_bug.cgi?id=357190#c15 for reporting the bug to Microsoft, because they do listen and they did fix the bug for xbox.com.
Duplicate of this bug: 383221

Updated

11 years ago
OS: Mac OS X → All
Hardware: Macintosh → All
Duplicate of this bug: 383900

Comment 8

11 years ago
Testing with the most recent nighly build appears to have the same problem on my Intel Mac.  However, testing with 1.5 on my old PPC based Powerbook, the page seems load properly.

Comment 9

11 years ago
I'm told the place to report issues with Live.com and Spaces is:
http://support.live.com/default.aspx

I submitted an error report this morning.  You may wish to do the same.

Comment 10

11 years ago
Phil Holden and Rob Dolin of the Live.com and Live Spaces teams indicate a fix should be online for this soon.  

Comment 11

11 years ago
This has been resolved and now loads properly in Camino.  Rob Dolin seems to be the right contact at MSFT for spaces related issues.

Comment 12

11 years ago
WFM too

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072112 Minefield/3.0a7pre ID:2007072112 [cairo]

--> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.