Tooltips appear on wrong screen when new display is hotplugged while Firefox is open

RESOLVED DUPLICATE of bug 314279

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 314279
11 years ago
11 years ago

People

(Reporter: Eoban Binder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

If a new display is added while Firefox is open, a number of Firefox UI elements do not become aware of the new display until re-launch of Firefox.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox.
2. Plug in a second DVI display.
3. Drag the Firefox window over to new display.
3. Invoke a tooltip or pop-down URL history list.
Actual Results:  
The tooltip or history pop-down box displays on the wrong screen.

Expected Results:  
What should happen is that the tooltip or history box should display on the same screen that the Firefox window is currently on.

I have a 1.5 GHz 15" PowerBook G4 running 10.4.9.  I am using the built-in DVI-out with a DVI display (no adapter).  I am unaware if this happens with the s-video or VGA, or with other video cards, or with other versions of Mac OS X, because I don't have that stuff available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314279
You need to log in before you can comment on or make changes to this bug.