if app.update.url points an existing, but malformed document, we get a 404 and not a 200

RESOLVED DUPLICATE of bug 451164

Status

()

RESOLVED DUPLICATE of bug 451164
11 years ago
10 years ago

People

(Reporter: moco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Would software would handle a 404 in the same way as a malformed doc (the downlaods html)?

When I point app.update.url.override to a bad .xml file, for example a html
page (like the downloads.html) I get the same 404 in the update UI.

this seems like a bug, since it is not a 404.

I think the problem is here:

http://lxr.mozilla.org/seamonkey/source/toolkit/mozapps/update/src/nsUpdateService.js.in#1982

note, we appear to have code to handle 200 errors, see http://lxr.mozilla.org/seamonkey/source/toolkit/mozapps/update/src/nsUpdateService.js.in#2010
yes, if you set app.update.log.Checker to true and app.update.url.override to http://www.sspitzer.org/index.html (an invalid updates xml file, clearly) you will see that we do detect a malformed xml file, but we report a 404.

from my error console:

There was a problem with the update service URL specified, either the XML file was malformed or it does not exist at the location specified. Exception: 

Transfer Error: AUS: Update XML File Not Found (404), code: 404

so we mask the XML malformed as a 404, which is a bug.
for one way to get the 200 error code, see bug #312661.  (we should not be presenting a 200 in that scenario.)

for another way, see also bug #376273.  again, we should not be presenting a 200 in that scenario either.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
This was fixed by bug 451164... resolving dupe
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451164
You need to log in before you can comment on or make changes to this bug.