No 64-bit Solaris nightly builds...

RESOLVED FIXED in M13

Status

SeaMonkey
Build Config
P2
major
RESOLVED FIXED
20 years ago
14 years ago

People

(Reporter: Roland Mainz, Assigned: Brian Ostrom)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
No real bug, but there are no solaris sparc nightly builds

Updated

20 years ago
Assignee: don → cyeh
Component: Apprunner → Build Config

Comment 1

20 years ago
Re-assigned to cyeh@netscape.com and changed component to Build Config.

Chris, know about this one?

Updated

20 years ago
Severity: trivial → major
Priority: P3 → P2
QA Contact: 3853 → 3796
Target Milestone: M4

Comment 2

20 years ago
Not a M3 blocker...setting to M4.

Updated

20 years ago
Assignee: cyeh → briano
QA Contact: 3796 → 2433
Summary: NO REAL BUG: No Solaris nightly builds... → No Solaris nightly builds...

Comment 3

20 years ago
when we do get solaris nightly builds, coordinate with leaf so they go to the
magic /h/chrome place for mozilla daily builds
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Target Milestone: M4 → M5

Comment 4

20 years ago
moving to m5
(Assignee)

Updated

20 years ago
Assignee: briano → donm
Status: ASSIGNED → NEW
(Assignee)

Comment 5

20 years ago
I've made the necessary changes so that the nightly build system
will successfully handle Solaris/SPARC builds.  Don has graciously
agreed to do the nightly builds and deliver them, so I'm reassigning
this bug to him.
(Assignee)

Comment 6

20 years ago
*** Bug 4003 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Assignee: donm → briano

Comment 7

20 years ago
Brian O has agreed to take this on and it should be fixed.  Assigning to
him to close.
(Reporter)

Comment 8

20 years ago
Is it possible to get a Solaris Sparc counterpart of the Win32 build 1999-04-27
{IMHO the best build until now :-))) } ?
Or should I ask briano@netscape.com directly ?

Comment 9

20 years ago
did we build/deliver solaris this morning? if answer is yes, then let's close
this. if the answer is no, what needs to be done to make this happen?
(Reporter)

Comment 10

20 years ago
ftp://ftp.mozilla.org/pub/mozilla/nightly/1999-04-28-09/ contains only a build
for irix/sgi; a 1999-04-29*/ directory is public available yet (29.4.99 / 20.14h
MET)
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

20 years ago
I have been doing nightly Solaris/sparc builds for the past
week now.  That is not a problem.  The problem is that I don't
know what I'm supposed to do after that.  I've been simply
packaging the dist/bin directory, after stripping the binaries,
but even gzip'd, this results in a 14MB .tar.gz file.  Something
I'm doing (or not doing) is wrong.  14MB is too much to expect
anyone to be willing to wait to download.  In my opinion.

I am working on this.  Immer noch....
(Reporter)

Comment 12

20 years ago
14 MB won't hurt me, even 30 MB won't. My system can do the download without my
help :-)
Possible options (in my optinion):
a) Delay solaris nightly builds until the 14+ MB has been fixed (preferred by
the FTP admin: no large downloads...:-)      )
OR
b) Do the solaris nightly builds now, even with this big archive size, and write
a bug report about the problem... (preferred by me)

I don't have any idea about the 14MB problem, but maybe I have an idea when I
see a living archive...

Aber so eilig hab' ichs damit auch wieder nicht. Derzeit nutze ich die
Win32-Version zur Vorführung. Muß nur immer noch den Laptop mitschleppen...
nicht so toll :-(
(Assignee)

Comment 13

20 years ago
Besser als einen SparcStation und Monitor mitschleppen, oder?  ;-)

Aber ich tu' was ich kann.  Hoffentlich heute abend gibt es etwas
fuer Solaris/sparc am ftp://ftp.mozilla.org/.
(Reporter)

Comment 14

20 years ago
Wir haben bei uns im Klinikum viele Sun Sparcs im Einsatz, da brauch ich gar
nichts (au0er Kopien und Stifte für die Whilteboards) schleppen, nur eine Sparc,
die frei ist und Solaris >= 2.5.1 drauf hat... Nur für größrere Vorlesungen muß
wegen des Projektors eine Sparc vorbereiten...
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

20 years ago
I've solved the size problem and written a simple script to
deliver the nightly builds.  Starting Monday there will be
Solaris 2.5.1 builds available daily on the FTP server.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 16

19 years ago
Reopened the bug, now for sparcv9 (64bit) sparc nightly builds...

Updated

19 years ago
Resolution: FIXED → ---

Comment 17

19 years ago
Clearing FIXED resolution due to reopen.

Updated

19 years ago
Target Milestone: M5 → M12

Comment 18

19 years ago
Moving to M12 since M5 id way over...

Updated

19 years ago
Target Milestone: M12 → M13
(Assignee)

Comment 19

19 years ago
Removed donm from the CC: list since he no longer works here.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 20

19 years ago
I don't know if we can do this yet with the systems we currently have.
What version(s) of Solaris support the sparcv9 flag?
(Reporter)

Comment 21

19 years ago
All Solaris 2.7 or Solaris 2.8 machines with UltraSPARC hardware running the
64bit kernel. Pre-UltraSPARC machines can run Solaris 2.7/2.8 only with the
32bit kernel, not with the 64bit one...

Test this with "isainfo -v" (the "isainfo" command shows which "ISA" codesets
are supported):
-- snip --
64-bit sparcv9 applications
32-bit sparc applications
-- snip --
sparc means that sparcv7,v8 code is supported, sparcv9 means 64bit sparc.

If you don't have a Solaris 2.7 test machine ready, think about setting up a
machine (UltraSPARC) with Solaris 2.8 beta.
For production usage, I recomment Solaris 2.7 SPARC with MU4 (Maintaince update
4, which kills all serious issues in Solaris 2.7).

Updated

19 years ago
Summary: No Solaris nightly builds... → No 64-bit Solaris nightly builds...

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → FIXED

Comment 22

19 years ago
give the nightly's/m13 a try.  briano checkin something that
might get a few more people running.

Comment 23

19 years ago
uh, we still have no sparc 64 bit builds like the bug says.  reopening
(Reporter)

Comment 24

19 years ago
1st problem is to manage it that the Zilla can be compiled with Sun Workshop
compilers (4/5/6EA) in 32bit mode - because the Workshop compilers are currently
the only sparcv9-compilers which are producing useable code - gcc sparcv9 is
very far away ;-(
Seems we've to kill a LOT of compillation errors...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.