Single day Event spanning multiple days near from 2301 - 2359

RESOLVED WONTFIX

Status

Calendar
General
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: James Peterson, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: 0.3.1

When creating a new event bwtween the times 2301 - 2359 the event schedular tries to create an event that spans the current and the next day.  This is due the way that the scheduler is pallning its dates.  It auto selects the current hour and adds one hour for the default time setting.  When near midnight this causes a multiday event selection.

Reproducible: Always

Steps to Reproduce:
1.Between the hours 2301 - 2359
2.Attempt to add a new event on any date.
3.Notice the dates on the event scheduler
Actual Results:  
From  = date
To = date + 1

This is because of the default hour selection but it still spans multiple dates.

Expected Results:  
I expect that when I am planning future events that most of them will not be happening at the current time that I am creating the event.

Though the determination of auto selecting an hour as the default event span may have been a decision I believe this will cause headaches with the general public.

I think it would be more efficient to have a default time setting in the event scheduler such as the start time of the work day or have the times read the same.  ie.  if its 12:34 when the new event is created then the defualt times in the event scheduler would both read 12:34.

Comment 1

11 years ago
That is because default event length is 60 minutes. You can set default event length in general properties. So I think it's won't fix or invalid.
Whiteboard: [qa discussion needed]

Comment 2

10 years ago
There are preferences to change this behavior.  I am with Omar that this is something we won't fix.  The choice of what to display in the event dialog works most every time in every case.  If we defaulted to a standard time, then it would not work as well in many other cases.

Marking --> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.