Links on dictionary page is 404 Not Found if JavaScript is turned off

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Dictionaries
--
trivial
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Jesper Kristensen, Assigned: Jesper Kristensen)

Tracking

Details

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

If JavaScript is turned off, all links to dictionaries on the dictionary page returns 404 Not Found, because the locale and the product is added twice to the url.

Reproducible: Always

Steps to Reproduce:
1. Turn off JavaScript
2. Go to https://addons.mozilla.org/da/firefox/browse/type:3
3. Click on en-US 
Actual Results:  
This page is displayed:
https://addons.mozilla.org/da/firefox/da/firefox/downloads/file/11757/united_states_english_dictionary-2.0.0.6-fx+zm+tb.xpi

Expected Results:  
This page should be displayed:
https://addons.mozilla.org/da/firefox/downloads/file/11757/united_states_english_dictionary-2.0.0.6-fx+zm+tb.xpi
Reducing severity: noscript support is so 1998.
Severity: normal → trivial

Updated

11 years ago
Assignee: nobody → bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Fixed by Jesper in bug 380305.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.