SVG text fill not rendered when included within a SVG element

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: JP Fiset, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

986 bytes, image/svg+xml
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

This problem appears to be MAC OS related. Also, it affects FF2, not Grand Paradiso. Not reproducible on Windows.

When a svg element is included with a svg document, children text node do not render the fill. The test stroke, if specified, is rendered correctly. However, the fill (which is the default rendering of text) is not.

Reproducible: Always

Steps to Reproduce:
1. Create a SVG document
2. Within SVG document, create SVG element
3. Within SVG element, create a text element and provide some test
Actual Results:  
In FF2 on MAC OS, the text is not rendered. 

Expected Results:  
The text should be rendered as if it was included directly in the SVG document.

This problem seems related to bug 351680. However, bug 351680 works OK for me, but the stated issue still happens.
(Reporter)

Comment 1

11 years ago
Created attachment 264470 [details]
Test case

Comment 2

11 years ago
Confirmed broken in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
WFM in trunk, Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070613 Minefield/3.0a6pre

The rendering of the text is fine, but the border of the box is still too thin - that is bug 380409 though.
Since we're focusing virtually exclusively on development for Firefox 3 now, closing as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.