Closed Bug 380429 Opened 13 years ago Closed 13 years ago

Default search engine not preserved when updating from 2003->2004RC2

Categories

(Firefox :: Search, defect, P1, blocker)

2.0 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 2

People

(Reporter: marcia, Assigned: Gavin)

References

Details

(Keywords: regression, verified1.8.1.4)

Attachments

(4 files)

Seen while testing updates.

STR:

1. With a fresh profile, install the Mac ja-JP 2.0.0.3 release build from the ftp directory. Change the channel to betatest manually to get the update. Confirmed after install that Google is set as the default search plugin.
2. Perform a partial update to 2004 RC 2.
3. Confirm after the update that the search plugin default is now Yahoo Japan.

Expected: The search plugin should be Google.

juanb can confirm the same thing is seen on the Mac Korean build.
Flags: blocking1.8.1.4?
Can you please list the files in appdir/searchplugins before and after the update?
Changing to all, since i see this also on Windows XP.

2 things i want to add to this bugreport.

After the update from 2003 the default homepage is still google :
http://www.google.de/firefox?client=firefox-a&rls=org.mozilla:ja:official

The default search plugin is yahoo (like described in this bugreport) :
http://search.yahoo.co.jp/search?p=Test&ei=UTF-8&fr=moz2&rls=org.mozilla:ja-JP:official

When i start the updated build with a new profil, the search default provider
is back google again.

So it seems this problem exists only with the profile you use when you update
from 2003 to 2004 RC2
This sounds like a problem with the code added in bug 364297 - on upgrade we replace any existing pref overrides the new build's shipped overrides. Now that we've shipped 2002, though, the "existing profile defaults" aren't Yahoo anymore, so the overrides shouldn't be in place. We need to remove the existing-profile-defaults (http://lxr.mozilla.org/l10n-mozilla1.8/find?string=existing) so that we don't do this.

If this theory is correct, this would have affected 2002->2003 upgrades, with profiles created by 2002.
(In reply to comment #5)
> We need to remove the
> existing-profile-defaults
> (http://lxr.mozilla.org/l10n-mozilla1.8/find?string=existing) so that we don't
> do this.

Of course if we do this, then upgrades from 2001->2004 won't get the benefits of that patch - users using the default homepage would be changed from Yahoo to Google. 

> If this theory is correct, this would have affected 2002->2003 upgrades, with
> profiles created by 2002.

Tracy has tested and this bug does indeed affect that upgrade path too.
confirmed also on windows with 2002 -> 2003 update
OS: Mac OS X → All
This is blocking 1.8.1.4 (after talking with juanb and dveditz)... so let's get an owner on this ASAP.  We hope to respin for rc3 on Monday if we can get a good patch. 
Flags: blocking1.8.1.4? → blocking1.8.1.4+
If the fix is going to change the originally intended behavior from when we switched to Google for CJKT (for 2.0.0.2, I think), we should probably get someone from the products team to chime in also.
If we remove the files as mentioned in comment 5, the only negative impact will be on CJKT users who use the search/homepage defaults, and who upgrade from 2.0.0.1 or earlier to 2.0.0.4 or later, *without* going through 2.0.0.2 or 2.0.0.3. Those users will have their defaults changed from Yahoo to Google when they upgrade to 2.0.0.4 or later.

I think that is a relatively unlikely scenario, certainly less likely than going through 2003->2004, so it seems that while this might not be a perfect approach, it probably is the best (and the only one I can think of at the moment). It's also a simple file removal that makes the CJKT builds behave in the same way as all of the non-CJKT builds, so there's little risk of causing further unknown problems.

Users that have gone from 2002->2003 have already been affected by this bug and had their defaults change, and I haven't heard of any reports about that, so maybe we're lucky and this isn't affecting as many users as it could be.
I can't think of any other solutions at this point, but perhaps Benjamin or mconnor have insight to add here.
Gavin, if there's no other solution that you guys can come up with, then let's go with the scenario that affects the least number of users as you have described in Comment 10.
This implements the solution from comment 10.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #264762 - Flags: review?(mconnor)
Blocks: 364297
Keywords: regression
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → Firefox 2
Comment on attachment 264762 [details] [diff] [review]
patch (remove existing-profile-defaults for CJKT)

r=me
Attachment #264762 - Flags: review?(mconnor) → review+
Attachment #264762 - Flags: approval1.8.1.4?
Comment on attachment 264762 [details] [diff] [review]
patch (remove existing-profile-defaults for CJKT)

approved for 1.8.1.4, a=dveditz
Attachment #264762 - Flags: approval1.8.1.4? → approval1.8.1.4+
Fixed on the branch by removing the following files from the l10n repo:
l10n/ja-JP-mac/browser/existing-profile-defaults.js 	l10n/zh-CN/browser/existing-profile-defaults.js 	l10n/zh-TW/browser/existing-profile-defaults.js 	l10n/ko/browser/existing-profile-defaults.js 	l10n/ja/browser/existing-profile-defaults.js 
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1.4
Resolution: --- → FIXED
This is needed for new users of 2002 that haven't upgraded to 2003 yet, or new 2003 users.
Attachment #264786 - Flags: review?(mconnor)
Attachment #264786 - Flags: approval1.8.1.4?
Attachment #264786 - Flags: review?(mconnor) → review+
Comment on attachment 264786 [details] [diff] [review]
add to removed-files.in too

approved for 1.8.1.4, a=dveditz
Attachment #264786 - Flags: approval1.8.1.4? → approval1.8.1.4+
Forgot to mention that I checked this in for Gavin shortly after the approval.
verified fixed 1.8.1.4 after tests with :

Mozilla/5.0 (Windows; U; Windows NT 6.0; ko; rv:1.8.1.3) Gecko/2007030919 Firefox/2.0.0.3 -> Update to Mozilla/5.0 (Windows; U; Windows NT 6.0; ko; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4

also for ja, zh-CN and zh-TW

Default search engine is preserved and its google. Verified on Windows Vista and Linux Fedora FC6 -> adding verified keyword
You need to log in before you can comment on or make changes to this bug.