Fx randomly fails to display non-BMP ideographs

VERIFIED FIXED

Status

Core Graveyard
GFX: Win32
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

({intl, jp-critical, verified1.8.1.5})

1.8 Branch
x86
Windows Vista
intl, jp-critical, verified1.8.1.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: branch-only)

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
Steps to reproduce:
1. Set "MS PGothic", "MS PMincho" or "Meiryo" as default on your font preference.
2. Open the attached testcase.
Actual result:
Many characters are displayed as middle-dot or blank-box.
Expected result:
All characters should be displayed.

This is significant for Japanese users because Vista default Japanes fonts have only a few glyphs in Ext.B range.
(Assignee)

Comment 1

11 years ago
Created attachment 264590 [details]
testcase
(Assignee)

Comment 2

11 years ago
Created attachment 264591 [details] [diff] [review]
patch (branch only)

|new PRUint32[]| DOESN'T initialize the array.
Assignee: win32 → VYV03354
Status: NEW → ASSIGNED
Attachment #264591 - Flags: superreview?(rbs)
Attachment #264591 - Flags: review?(rbs)
(Assignee)

Updated

11 years ago
Attachment #264591 - Attachment description: patch → patch (branch only)

Comment 3

11 years ago
Comment on attachment 264591 [details] [diff] [review]
patch (branch only)

r+sr=rbs
Attachment #264591 - Flags: superreview?(rbs)
Attachment #264591 - Flags: superreview+
Attachment #264591 - Flags: review?(rbs)
Attachment #264591 - Flags: review+
(Assignee)

Comment 4

11 years ago
Comment on attachment 264591 [details] [diff] [review]
patch (branch only)

We couldn't test this on trunk because trunk can no longer build without cairo.
This is a simple one-liner and fix a significant problem for Japanese users.
Attachment #264591 - Flags: approval1.8.1.5?
(Assignee)

Updated

11 years ago
Flags: blocking1.8.1.5?
Keywords: jp-critical
Comment on attachment 264591 [details] [diff] [review]
patch (branch only)

approved for 1.8.1.5, a=dveditz for release-drivers

But not blocking the release.
Attachment #264591 - Flags: approval1.8.1.5? → approval1.8.1.5+
Flags: blocking1.8.1.5?
Whiteboard: branch-only
checked-in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.5
Resolution: --- → FIXED
(Assignee)

Comment 7

11 years ago
-> v.
using latest nightly Fx2 branch.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.5 → verified1.8.1.5
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.