Firefox crash when many windows opened by a script and new windows opened in new tabs

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Joachim Rousseau, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

when reaching the website https://particuliers.secure.lcl.fr (a famous French bank), it opens 4 new windows. As specified by my Firefox preferences, they are openned in 4 new tab.
Or they had too... instead, Firefox simply crashes !

Reproducible: Always

Steps to Reproduce:
1.Go to https://particuliers.secure.lcl.fr

Actual Results:  
Browser crash

Expected Results:  
https://particuliers.secure.lcl.fr loads and 4 new window (or 4 new tabs) are opened. 

I don't know if the popup blocker should have blocked it, but this is not the point here.
Konkeror doesn't crash and works as expected (4 tabs opened, non crash)
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
I don't see 4 tabs or windows on this page and I don't see blocked pop-up notifications. See http://kb.mozillazine.org/Firefox_crashes for the crash.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309
> Firefox/2.0.0.3
> I don't see 4 tabs or windows on this page and I don't see blocked pop-up
> notifications. See http://kb.mozillazine.org/Firefox_crashes for the crash.
> 
The other (unexpected) behaviour is a redirection to immobilier.lcl.fr If you click on "back" button --> Crash.
If the crash may be caused by Flash plugin (it is used on particuliers.secure.lcl.fr), the redirection is unexpected.
(Reporter)

Comment 3

11 years ago
This bug was due to an unknown quirck behaviour with Flash plugin (Only pages with Flash applets where subjects to this bug, not all, but every time on pages where bug was encoutered).
The bug disappeared, but I think it may happend on every new installation of Feisty Fawn amd64 + Firefox + Flash plugin.

Now I have a more "normal" behaviour : Flash works, or its says the latest version is needed, or Firefox crashes in the "normal way", but I have no multiple dirty redirections.

I don't know how and why this bug came, nor why and how it stopped.
Severity: critical → normal

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Component: Tabbed Browser → Plug-ins
Product: Firefox → Core
QA Contact: tabbed.browser → plugins
Version: 2.0 Branch → 1.8 Branch

Comment 4

7 years ago
I've just had this kind of issue (but my tabs were manually opened).
I do use a lot of extensions.


Here is the crash : bp-03c35785-726b-4102-bb20-c9cb42120220


Should I open à new bug?

Hope it may help.
You need to log in before you can comment on or make changes to this bug.