don't strike out "cancel and return to" it makes the link unreadable

VERIFIED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

2.23.3
Bugzilla 3.0
Bug Flags:
approval +
approval3.0 +

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
don't strike out "cancel and return to" it makes the link unreadable.

steps:
1. open a resolved bug
2. try to change its product

expected results:
be able to read the link for cancel and return to.

actual results:
it's a royal pain

compare
OK:
Changes submitted for <span class="bz_closed"><a href="show_bug.cgi?id=378456" title="RESOLVED INVALID - Crashes when choosing a download file save location [@ TNavNode::TNavNode[in-charge](TNavNode const&amp;)]">bug 378456</a></span></dt>

Bad:
<span class="bz_closed"><a href="show_bug.cgi?id=378456" title="RESOLVED INVALID - Crashes when choosing a download file save location">Cancel and Return to bug 378456</a>

Comment 1

11 years ago
Agreed.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Comment 2

11 years ago
Created attachment 267898 [details] [diff] [review]
extract cancel text from link
Assignee: create-and-change → timeless
Status: NEW → ASSIGNED
Attachment #267898 - Flags: review?(mkanat)

Comment 3

11 years ago
Comment on attachment 267898 [details] [diff] [review]
extract cancel text from link

Looks good.
Attachment #267898 - Flags: review?(mkanat) → review+

Updated

11 years ago
Flags: approval3.0+
Flags: approval+

Comment 4

11 years ago
timeless committed the patch 3 days ago but forgot to close the bug:

tip:

template/en/default/bug/process/verify-new-product.html.tmpl new: 1.21 old: 1.20

3.0:

template/en/default/bug/process/verify-new-product.html.tmpl new: 1.20.2.1 old: 1.20
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Correct behavior seems to be demonstrated on landfill now. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.