session restore won't work if Downloads window remains open

RESOLVED DUPLICATE of bug 354894

Status

()

--
minor
RESOLVED DUPLICATE of bug 354894
12 years ago
12 years ago

People

(Reporter: mariusads, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I've configured Firefox to keep the same tabs open if I close the browser and restart it (Tools>Options>When Firefox starts: Show my windows and tabs from last time)
If by accident I forget to close the Downloads window before closing the browser, the next time it loads without any session data, no tabs will be opened(maybe because it treats the Downloads window as a browser window).


Reproducible: Always

Steps to Reproduce:
1. Set the option When Firefox starts: Show my windows and tabs from last time
2. Open some websites in tabs.
3. Close the browser
4. Reopen the browser, you will see that tabs are recreated.
5. Open the Downloads window
6. Close the browser
7. Close the Downloads window
8. Restart the browser, you will see that it does not load any tabs.
Actual Results:  
Tabs are not recreated

Expected Results:  
The browser should maybe close the Downloads window or ignore it, in order to load the tabs next time the browser starts. 

However having the Downloads window open if the main window is closed is useful, I think it shouldn't be changed.

Maybe it happens with other windows as well, that remain open after the main window of the closes. If all browser windows that contain pages are closed, the session should be saved, not when all browser windows are closed (I don't know how Firefox works, it's just how I imagine it)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354894
You need to log in before you can comment on or make changes to this bug.