If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

4 "undefined" strings on edit page

RESOLVED WONTFIX

Status

Mozilla Developer Network
General
--
minor
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: himorin, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

4 clickable "undefined" strings are displaied on editing page.
it appeares near to the icon over edit box.

it might be an undefined edit icons??

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
They are indeed supposed to be edit icons. The generated code is:

<img style="cursor: pointer;" title="undefined" alt="undefined" src="undefined" border="0" height="22" width="23">

Note that they don't appear with the "MDC" skin, only on with the "Devmo (default)" skin.
(Reporter)

Comment 2

11 years ago
Created attachment 266252 [details] [diff] [review]
might be working patch?

i think this is caused by prototype.js's bug.
'extend' and 'flatten' objects are added to mwEditButtons and mwCustomEditButtons. and from these two objects on two buttons array makes
four (two x two = four) 'undefined' strings

as Benoit says, this doesn't occur on MDC skin, and the diff between two 
prototype.js files is below. so, i think this will be fixed with this patch.

% diff -r skins/mdc/prototype.js skins/devmo/prototype.js
948d947
< if(window.attachEvent)
The problem is still present. 

Does the patch solves it?
(Reporter)

Updated

10 years ago
Attachment #266252 - Flags: review?(eshepherd)
No, this patch doesn't fix the problem.  You can try it out at http://developer-stage.mozilla.org -- still happens, even with the patch.
(Reporter)

Comment 5

10 years ago
Created attachment 280037 [details] [diff] [review]
patch ver.2

(In reply to comment #4)
> No, this patch doesn't fix the problem.  You can try it out at
> http://developer-stage.mozilla.org -- still happens, even with the patch.

hmm..

with testing on my virtual machine, it seems that it caused by confliction of prototype.js and wikibits.js
this is one line patch working on my test server.
Attachment #266252 - Attachment is obsolete: true
Attachment #266252 - Flags: review?(eshepherd)
WONTFIX as we switch to Deki.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Component: Deki Infrastructure → Other
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.