Address Book Lists - Two names different but same email address - second name replaced by first name

RESOLVED DUPLICATE of bug 189895

Status

Thunderbird
Address Book
--
major
RESOLVED DUPLICATE of bug 189895
11 years ago
11 years ago

People

(Reporter: Steve Elzholz, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Thunderbird 2.0.0.0 (20070326)

Setting up an address book with the following names:
   First Entry
First Name - Barry
Last Name - Smith
Display Name becomes - Barry Smith
email address - Bsmith@aol.com

Second entry:
First Name - Dylan
Lat Name - Smith
Display Name becomes - Dylan Smith
email address - bsmith@aol.com

Now set up a list under the address book - adding both names and email addresses, which are the same for both cards - to the list.

After entering the second card into the list - the First name on both cards in the List becomes Barry and the Display names are changed to the Barry Smith. In the main Address Book, the cards remain correct.

Reproducible: Always

Steps to Reproduce:
1. Use the same email address for two cards in a list
2.
3.
Actual Results:  
See above.

Expected Results:  
The cards in the list should have the correct first, last and display names.

The cards in the list should have the correct first, last and display names as entered into the list.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
Confirmed on Debian GNU/Linux with
 version 2.0.0.4pre (20070513)
 version 3.0a1 (20070511)


Also, new cards are added to the address book when creating the list.
OS: Windows XP → All

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 189895
You need to log in before you can comment on or make changes to this bug.