Bookmark Manager: Creating or Pasting bookmarks doesn't use current folder

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Dirk Schoettler, Unassigned)

Tracking

2.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Hello,

within the bookmark manager, if I opened a folder and want to insert a bookmark (either with "New" or by "Paste" from a copied one), the bookmark isn't inserted in the open folder, but to the root of bookmarks.

This seems to be a similar effect to 321092 (Creating menus) or 272626 (pasting bookmarks).

Obviously, the currently shown folder is not a kind of context. (By the way: A context menu would be very comfortable. ;-) )

Reproducible: Always

Steps to Reproduce:
1.open the bookmark manager
2.click onto a folder in the left pane (so its bookmarks are shown)
3.create a new bookmark (or paste it with Ctrl-V)

Actual Results:  
The inserted bookmarks are listed at the root of bookmarks.

Expected Results:  
The inserted bookmarks, folders, etc. should come into the currently marked (or open) folder.

The inconvenience here is, that to get them into the correct folder, you have to drag and drop them in a second step after creating them. Especially if you enter many bookmarks, thats extra work.

Take a look at Thunderbird or Mozilla Mail. I think, if you create a new subfolder or move mails, you are asked, into which folder this action shall happen. As well, a context menu is available for creating and pasting, I think.

Comment 1

10 years ago
mh this sounds working on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215 Minefield/3.2a1pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.