If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IMAP Drafts folder auto-created even when specified to use local folder (and can't delete)

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
minor
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Chris Petersen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

I don't need to clutter my server up with a Drafts folder, so I have all of my IMAP accounts set to use the local folder instead.  However, I often open Thunderbird up to discover that it has recreated this folder, and given it the special "can't delete" status and the special Drafts icon.  Checking my prefs (and testing by saving a draft message) verifies that drafts are still set to go to the local Drafts folder.

I have to log into the mail server to delete the Drafts folder manually, wiping it from the subscribed folders file, and then deleting TBird's cache directory.  Things work fine for a few days, but the Drafts folder eventually finds its way back.

Reproducible: Sometimes

Updated

9 years ago
Assignee: mscott → nobody
Nikolay, I'm pretty sure Chris is gone. Have you encountered this at all?

If it still exists, there might be a dup amongst https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=anywordssubstr&field0-0-0=short_desc&bug_severity=normal&bug_severity=minor&bug_severity=enhancement&type1-0-1=substring&resolution=---&query_format=advanced&value1-0-0=folder&type0-0-0=anywordssubstr&value0-0-0=draft%20&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=component
Severity: normal → minor
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists

Comment 2

7 years ago
Latest versions of TB since like TB3 beta2 or 3 only creates drafts when it need save something to it. To make sure I've done test on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100926 Thunderbird/3.3a1pre and can't reproduce it. When you change your drafts folder "special" icon no more special just regular "folder" icon on drafts.
WFM per comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.