separators in bookmark manager dialog and bookmark sidebar have a (16px x 16px) blank space

VERIFIED FIXED in Firefox 3 alpha6

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Christine Yen)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 3 alpha6
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

separators in bookmark manager dialog have a (16x16px) blank space

see also bug #334669, where onemen.one fixed this for winstripe
Created attachment 264837 [details]
screen shot from the mac
Assignee: nobody → cyen
Target Milestone: --- → Firefox 3 alpha6
(Assignee)

Comment 2

11 years ago
Created attachment 267438 [details] [diff] [review]
patch
Attachment #267438 - Flags: review?
(Assignee)

Comment 3

11 years ago
Created attachment 267439 [details] [diff] [review]
patch

css tweak, doesn't change appearance on linux -- check windows?
Attachment #267439 - Flags: review?(sspitzer)
(Assignee)

Updated

11 years ago
Attachment #267438 - Attachment is obsolete: true
Attachment #267438 - Flags: review?
> css tweak, doesn't change appearance on linux -- check windows?

That patch would only affect mac, but I don't think it is the right fix.
(Assignee)

Comment 5

11 years ago
Created attachment 268124 [details] [diff] [review]
patch, in theright file

I would argue that it should still be the same fix, just a different file. No other trees to my knowledge use separators, so this patch should only affect the relevant trees within Places.
Attachment #267439 - Attachment is obsolete: true
Attachment #268124 - Flags: review?(sspitzer)
Attachment #267439 - Flags: review?(sspitzer)
Comment on attachment 268124 [details] [diff] [review]
patch, in theright file

clearing review, christine is working on a different patch
Attachment #268124 - Flags: review?(sspitzer)
(Assignee)

Comment 7

11 years ago
Created attachment 268158 [details] [diff] [review]
patch #3, just kidding about the other two

As Seth pointed out, the error was caused by the renaming of a tree-col from "Name" in places.xul to "title," and therefore the ineffectiveness of the existing "treechildren::-moz-tree-twisty(Name, separator) { -moz-appearance:none; }" in mozilla/toolkit/themes/pinstripe/global/tree.css...
Attachment #268124 - Attachment is obsolete: true
Attachment #268158 - Flags: review?(sspitzer)
Status: NEW → ASSIGNED
Flags: blocking-firefox3?
Comment on attachment 268158 [details] [diff] [review]
patch #3, just kidding about the other two

r=sspitzer
Attachment #268158 - Flags: review?(sspitzer) → review+
Summary: separators in bookmark manager dialog have a (16x16px) blank space → separators in bookmark manager dialog and bookmark sidebar have a (16px x 16px) blank space
fixed.

Checking in places.css;
/cvsroot/mozilla/browser/themes/pinstripe/browser/places/places.css,v  <--  places.css
new revision: 1.10; previous revision: 1.9
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
reminder to Christine to log spin off bugs:

1) the bug that "padding: 0px;" fixes is also a bug in Firefox 2
2) the potential removal or cleanup of the "Name" / separator rules in tree.css
> 1) the bug that "padding: 0px;" fixes is also a bug in Firefox 2

see bug #384236

> 2) the potential removal or cleanup of the "Name" / separator rules in tree.css

no bug logged because Seamonkey bookmark/history UI uses "Name" tree-cols, and they are/will use toolkit, seamonkey will need those rules.
Depends on: 384236
No longer depends on: 384236

Comment 12

11 years ago
(In reply to comment #11)
>>2) the potential removal or cleanup of the "Name" / separator rules in tree.css
>no bug logged because Seamonkey bookmark/history UI uses "Name" tree-cols, and
>they are/will use toolkit, seamonkey will need those rules.
Actually we already appear to use similar rules in our bookmarks.css:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/themes/classic/communicator/bookmarks/bookmarks.css&rev=1.42&mark=48-50,53-55,58-60,63-65,72-74,86-88,90-92,94-97,99-101#90

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
verified with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a7pre) Gecko/2007070504 Minefield/3.0a7pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.