Closed Bug 380836 Opened 14 years ago Closed 10 years ago

stop inheritance from nsISupports for CAccessibleXXX objects

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 575109

People

(Reporter: surkov, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

see bug 380508 for description.

neil@parkwaycc.co.uk   2007-05-12 11:48:16 PDT

(From update of attachment 264603 [details] [diff] [review])
>+class CAccessibleAction: public nsISupports,
I know you do this so that you can use do_QueryInterface, but you should know
that this bloats your object's memory footprint, although since you already
have at least 12 vtable entries, an extra one or two wouldn't seem to matter.
While you're at it make sure that we only expose IA2 interfaces when equivalent XPCOM interface is supported.

This is not always the case when the class supports the interface. Sometimes we have a "smart QI". For example, for nsHyperTextAccessible::QI we sometimes support nsIAccessibleText/nsIAccessibleEditableText/nsIAccessibleHyperText and sometimes not. So you have to check before exposing equivalent COM interface.
Blocks: cleana11y
No longer blocks: ia2
no nearest plans to work on it.
Assignee: surkov.alexander → nobody
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575109
Oops. Sorry for the duplication :-(
You need to log in before you can comment on or make changes to this bug.