offsetLeft and offsetTop for table elements are too large

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: dwendorf, Unassigned)

Tracking

({regression, testcase})

unspecified
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070515 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070515 Minefield/3.0a5pre

Between the 2007-03-15-04 and 2007-03-16-05 trunk builds, the offsetLeft and offsetTop calculations for tables were switched to more accurately reflect the size of the table, but the offsetLeft and offsetTop for child rows and cells were not switched, so they remain too large.

Reproducible: Always

Steps to Reproduce:
1. Create a table with some space between it and the top or left of its offsetParent
2. Add one row and cell to it.
2. Check the cell's offsetLeft or offsetTop.
Actual Results:  
The offsetLeft and offsetTop are calculated as if the table stretched almost to the top and left edges.

Expected Results:  
Because the table is spaced away from the edges, the cell's offsetLeft and offsetTop should be smaller, reporting only the space between the edge of the cell and the edge of the table.
(Reporter)

Comment 1

12 years ago
Created attachment 265077 [details]
Example table, detailed description, and comparison results from various builds
(Reporter)

Updated

12 years ago
Blocks: 372365
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
Depends on: 375003
Flags: blocking1.9?
Should be working now in builds dated 2007-06-14 or newer.
The mochitests on bug 375003 covers the attached testcase.

-> FIXED (by bug 375003)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
in-testsuite+ per comment 2.
Flags: in-testsuite+
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.