Not able to install bugzilla 3.0

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
--
critical
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: prabir, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: 3.0

I installed bugzilla 3.0 as per the instruction. But after installation when i tried to open the same in the browser using the url http:\\localhost, it shows me a page with the below mentioned data:-



#!/usr/bin/perl -wT
# -*- Mode: perl; indent-tabs-mode: nil -*-
#
# The contents of this file are subject to the Mozilla Public
# License Version 1.1 (the "License"); you may not use this file
# except in compliance with the License. You may obtain a copy of
# the License at http://www.mozilla.org/MPL/
#
# Software distributed under the License is distributed on an "AS
# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
# implied. See the License for the specific language governing
# rights and limitations under the License.
#
# The Original Code is the Bugzilla Bug Tracking System.
#
# The Initial Developer of the Original Code is Netscape Communications
# Corporation. Portions created by Netscape are
# Copyright (C) 1998 Netscape Communications Corporation. All
# Rights Reserved.
#
# Contributor(s): Jacob Steenhagen <jake@bugzilla.org>
#                 Frédéric Buclin <LpSolit@gmail.com>

###############################################################################
# Script Initialization
###############################################################################

# Make it harder for us to do dangerous things in Perl.
use strict;

# Include the Bugzilla CGI and general utility library.
use lib ".";

use Bugzilla;
use Bugzilla::Constants;
use Bugzilla::Error;
use Bugzilla::Update;

# Check whether or not the user is logged in
my $user = Bugzilla->login(LOGIN_OPTIONAL);

###############################################################################
# Main Body Execution
###############################################################################

my $cgi = Bugzilla->cgi;
# Force to use HTTPS unless Bugzilla->params->{'ssl'} equals 'never'.
# This is required because the user may want to log in from here.
if (Bugzilla->params->{'sslbase'} ne '' and Bugzilla->params->{'ssl'} ne 'never') {
    $cgi->require_https(Bugzilla->params->{'sslbase'});
}

my $template = Bugzilla->template;
my $vars = {};

# Return the appropriate HTTP response headers.
print $cgi->header();

if ($user->in_group('admin')) {
    # If 'urlbase' is not set, display the Welcome page.
    unless (Bugzilla->params->{'urlbase'}) {
        $template->process('welcome-admin.html.tmpl')
          || ThrowTemplateError($template->error());
        exit;
    }
    # Inform the administrator about new releases, if any.
    $vars->{'release'} = Bugzilla::Update::get_notifications();
}

# Generate and return the UI (HTML page) from the appropriate template.
$template->process("index.html.tmpl", $vars)
  || ThrowTemplateError($template->error());



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Which web server are you using?  Assuming IIS or Apache (Apache is supported.  Not sure if IIS is but I doubt anything besides those 2 are.)  Anyway, regardless of which server you're using perl's not touching the script before it's sent to the server so you need to configure it to do so however that is done for your server.

This issue is covered in the documentation at http://www.bugzilla.org/docs/3.0/html/configuration.html#http
See also http://www.bugzilla.org/docs/3.0/html/trbl-testserver.html

Please see http://developer.mozilla.org/en/docs/Bug_writing_guidelines before filing future bugs.
Bugzilla support is available at http://www.bugzilla.org/support/ and support for Mozilla Corporation products (not including Bugzilla) is available at http://www.mozilla.com/support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: Bugzilla-General → Installation & Upgrading
Resolution: --- → INVALID

Comment 2

11 years ago
s/to the server/to the client/

Comment 3

11 years ago
What Jeremy is trying to say is:

Bugzilla is not a support system. Bugzilla is for filing bugs.

The correct place to ask for support is on the bugzilla-support list, described here:

  http://www.bugzilla.org/support/
You need to log in before you can comment on or make changes to this bug.