Exception occurs while doing Shift+Reply in a HTML compose.

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: skasinathan, Assigned: bugzilla)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Steps:
1. Select a msg. 
2. Do Shift+Reply (Toolbar reply). Assuming you are in HTML mode, Shift+reply 
will bring a Plain text compose window. Notice that it throws couple of JS 
exceptions. 

 === onButtonUpdate called
 === onButtonUpdate called
 === onButtonUpdate called
JavaScript error:
chrome://messenger/content/messengercompose/MsgComposeCommands.js line 157: 
uncaught exception: [Exception... "Component returned failure code: 0x80004001 
(NS_ERROR_NOT_IMPLEMENTED) [nsIControlle
r.isCommandEnabled]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  
location: "JS frame :: chrome://global/content/globalOverlay.js :: 
goUpdateCommand :: line 221"  data: no]

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code: 
0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIController.isCommandEnabled]"  
nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENT
ED)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: 
goUpdateCommand :: line 221"  data: no]

Build and Platform:
2000-05-03-09-M16, Win NT.

Additional info: 
1. I could reproduce this in Plain text mode and without using Shift key.
(Assignee)

Comment 1

19 years ago
Accepting
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 2

19 years ago
moving to M18.  Does anything bad happen?
Target Milestone: M17 → M18

Comment 3

18 years ago
Moved to future milestone. If there is a bad end user visible behavior here, 
please add it to the bug so we can reconsider.
Target Milestone: M18 → Future

Comment 4

17 years ago
I can't reproduce this on Mac OS 9.1 with build 2001062008. 
(Assignee)

Comment 5

17 years ago
I don't see anymore those assertions. WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.