(foo instanceof Array) doesn't work across JS contexts

RESOLVED DUPLICATE of bug 339884

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 339884
11 years ago
8 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
In writing new JS module code for ArrayConverter (bug 380839), I noticed my module's ArrayConverter.nsIArray() method could not evaluate "(aArray instanceof Array)" to true under any circumstances.

For the native types, such as Array, Object, etc., it would be nice to have that evaluate to true when appropriate, so that I could throw an exception if it wasn't true.

I wonder if this bug is fundamentally a dupe of bug 339884.  I can provide a xpcshell testcase if so desired for components (I suspect the same bug may apply across XPCOM component boundaries).
(In reply to comment #0)
> I wonder if this bug is fundamentally a dupe of bug 339884.

Sure looks like it to me. See also bug 350558.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339884
You need to log in before you can comment on or make changes to this bug.