Checkbox in the exit/shutdown dialog (close multiple tabs) to control session saving now / restore on the next start.

RESOLVED DUPLICATE of bug 351774

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 351774
11 years ago
11 years ago

People

(Reporter: Aleksej, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Rationale: The session restore setting in Preferences → Main is unobvious, new bugs are filed often, asking for session restore after normal shutdown.

Request from #firefox:
May 17 15:43:52 dav7> you know how when quitting FF will ask "Close 864 tabs?", well, put an option underneath that says "[x] Reopen these tabs on next startup" :P
There is a Save Session extension for this function. It puts a "Save Session" option in the Tools menu and "Save Session & Exit" in the File menu. There are various extensions that provide a button "Restart Firefox" which restores tabs after restart.
Problem with a button on the Confirm Close window would be that a lot of people have this function disabled.
This bug looks so familiar to me that it could be a dupe. 
(Reporter)

Updated

11 years ago
Whiteboard: DUPEME?
(Reporter)

Comment 2

11 years ago
Note that it's a checkbox and not button here, because it may be easy to click the wrong button in hurry (when you are closing Firefox, you probably don't need it ftm anymore, as opposed to starting, when you might give it more attention).

Comment 3

11 years ago
DUPE of bug 351774?

IE7 uses a (quite well hidden) checkbox for the described behavior which IMO takes too many clicks to activate. I'd rather see this as a third button -- as implemented by the Session Fix extension (see https://addons.mozilla.org/firefox/4542 ) -- the difference between "Close Tabs" and "Save Session" plus the placement of the buttons should make it easy enough to hit the right button even if in a hurry.
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351774
(Reporter)

Updated

11 years ago
Whiteboard: DUPEME?
You need to log in before you can comment on or make changes to this bug.