Custom view does not show message with important tag

RESOLVED DUPLICATE of bug 355318

Status

RESOLVED DUPLICATE of bug 355318
12 years ago
12 years ago

People

(Reporter: thomas, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2
Build Identifier: version 2.0.0.0 (20070326)

I am using an IMAP account with uwimap 2006g.
I have a custom view "unread or important" which shows messages either not read OR tagged "important".

Since TB 2.0, this view does not show messages that were recently tagged as important. However it shows older messages that are tagged as "important".
If I select the "important" standard view, these newer messages are being shown, too.
I can "fix" this by deleting the .msf file and so forcing TB to reread all messages from the server.
When tagging another message as important, it will again not show in my custom view until I delete the .msf file.

This is a regression to TB 1.x. There it still works with the same IMAP account and without deleting the .msf file.

This bug is happening on Linux and Windows.

Reproducible: Always

Steps to Reproduce:
1. Sort messages "threaded" in a IMAP folder
2. Tag a message as "important"
3. Create custom view showing either "not read" OR "important"
4. Choose previously created custom view -> tagged message is not showing
5. Choose view "important" -> tagged message is showing

Actual Results:  
TB is not showing the "important" message in the custom view.

Expected Results:  
TB should show the "important" message in the custom view.

Temporary fix:
1. Leave TB and delete .msf file
2. Start TB, goto folder, choose custom view -> message is showing
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0
Tags is Important + Status isn't Read doesn't show the msg tagged Important. 
however, 
Tags contains Important + Status isn't Read works fine for me. 

Seems this is bug 355318.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355318
(Reporter)

Comment 2

12 years ago
Yes, this is a duplicate. But why was I able to "fix" this temporarily by deleting the .msf file?
You need to log in before you can comment on or make changes to this bug.