crash on shutdown, mObserver is null nsCacheService::CreateOfflineDevice()

RESOLVED DUPLICATE of bug 380968

Status

()

RESOLVED DUPLICATE of bug 380968
12 years ago
12 years ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

crash on shutdown, mObserver is null nsCacheService::CreateOfflineDevice()

note, I've only seen this once so far.

from my trunk debug Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070517 Minefield/3.0a5pre

from my console:

nsPluginHostImpl::Observe "xpcom-shutdown"
###!!! ASSERTION: Shouldn't have termination funcs by now: '!mTerminations', fil
e c:/builds/trunk-no-places/mozilla/dom/src/base/nsJSEnvironment.cpp, line 984
WARNING: nsExceptionService ignoring thread destruction after shutdown: file c:/
builds/trunk-no-places/mozilla/xpcom/base/nsExceptionService.cpp, line 191
--DOMWINDOW == 9
--DOMWINDOW == 8
###!!! ASSERTION: nsCacheEntryHashTable not initialized: 'initialized', file c:/
builds/trunk-no-places/mozilla/netwerk/cache/src/nsCacheEntry.cpp, line 451

here's my stack:

 	necko.dll!nsCOMPtr<nsILocalFile>::get_DerivedSafe()  Line 910 + 0x3 bytes	C++
 	necko.dll!nsCOMPtr<nsILocalFile>::operator nsDerivedSafe<nsILocalFile> *()  Line 842	C++
 	necko.dll!nsCacheProfilePrefObserver::OfflineCacheParentDirectory()  Line 124 + 0x12 bytes	C++
>	necko.dll!nsCacheService::CreateOfflineDevice()  Line 1094 + 0xb bytes	C++
 	necko.dll!nsCacheService::SearchCacheDevices(nsCString * key=0x046b9ea0, int policy=0, int * collision=0x0012f61c)  Line 1448 + 0x8 bytes	C++
 	necko.dll!nsCacheService::ActivateEntry(nsCacheRequest * request=0x04551ff8, nsCacheEntry * * result=0x0012f644)  Line 1350 + 0x1c bytes	C++
 	necko.dll!nsCacheService::ProcessRequest(nsCacheRequest * request=0x04551ff8, int calledFromOpenCacheEntry=1, nsICacheEntryDescriptor * * result=0x05c08284)  Line 1241 + 0x10 bytes	C++
 	necko.dll!nsCacheService::OpenCacheEntry(nsCacheSession * session=0x03c94640, const nsACString_internal & key={...}, int accessRequested=1, int blockingMode=0, nsICacheListener * listener=0x00000000, nsICacheEntryDescriptor * * result=0x05c08284)  Line 1318 + 0x15 bytes	C++
 	necko.dll!nsCacheSession::OpenCacheEntry(const nsACString_internal & key={...}, int accessRequested=1, int blockingMode=0, nsICacheEntryDescriptor * * result=0x05c08284)  Line 106 + 0x1b bytes	C++
 	necko.dll!nsHttpChannel::OpenCacheEntry(int offline=1, int * delayed=0x0012f7c0)  Line 1320 + 0x50 bytes	C++
 	necko.dll!nsHttpChannel::Connect(int firstTime=1)  Line 286 + 0x10 bytes	C++
 	necko.dll!nsHttpChannel::AsyncOpen(nsIStreamListener * listener=0x047ebb40, nsISupports * context=0x00000000)  Line 3556 + 0xd bytes	C++
 	places.dll!nsFaviconService::DoSetAndLoadFaviconForPage(nsIURI * aPage=0x0497ada0, nsIURI * aFavicon=0x0497ae88, int aForceReload=0)  Line 535 + 0x2d bytes	C++
 	places.dll!nsNavHistory::CommitLazyMessages()  Line 3202	C++
 	places.dll!nsNavHistory::LazyTimerCallback(nsITimer * aTimer=0x0493ebd0, void * aClosure=0x03dd85c8)  Line 3175	C++
 	xpcom_core.dll!nsTimerImpl::Fire()  Line 383 + 0x13 bytes	C++
 	xpcom_core.dll!nsTimerEvent::Run()  Line 458	C++
 	xpcom_core.dll!nsThread::ProcessNextEvent(int mayWait=1, int * result=0x0012fa14)  Line 483	C++
 	xpcom_core.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x00bad4d8, int mayWait=1)  Line 227 + 0x16 bytes	C++
 	xpcom_core.dll!nsThread::Shutdown()  Line 442 + 0xb bytes	C++
 	necko.dll!nsNotifyAddrListener::Shutdown()  Line 233 + 0x1c bytes	C++
 	necko.dll!nsNotifyAddrListener::Observe(nsISupports * subject=0x00ca5714, const char * topic=0x00353be0, const unsigned short * data=0x00000000)  Line 183	C++
 	xpcom_core.dll!nsObserverList::NotifyObservers(nsISupports * aSubject=0x00ca5714, const char * aTopic=0x00353be0, const unsigned short * someData=0x00000000)  Line 129	C++
 	xpcom_core.dll!nsObserverService::NotifyObservers(nsISupports * aSubject=0x00ca5714, const char * aTopic=0x00353be0, const unsigned short * someData=0x00000000)  Line 184	C++
 	xpcom_core.dll!NS_ShutdownXPCOM_P(nsIServiceManager * servMgr=0x00ca5714)  Line 721	C++
 	xul.dll!ScopedXPCOMStartup::~ScopedXPCOMStartup()  Line 793 + 0xc bytes	C++
 	xul.dll!XRE_main(int argc=3, char * * argv=0x00ba9818, const nsXREAppData * aAppData=0x004036e0)  Line 2871	C++
 	firefox.exe!main(int argc=3, char * * argv=0x00ba9818)  Line 65 + 0x13 bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 586 + 0x19 bytes	C
 	firefox.exe!mainCRTStartup()  Line 403	C
 	kernel32.dll!7c816fd7() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380968
You need to log in before you can comment on or make changes to this bug.