Multiple problems: corrupted file, empty HTTP realm, NTLM Authentication

RESOLVED FIXED

Status

()

Toolkit
Password Manager
--
major
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Jim, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070517 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070516 Minefield/3.0a5pre

NTLM authentication does not prompt for user/password but instead fails login. Words correctly on the 2007051504 nightly build but fails on the 2007051608 nightly. After reinstalling 2007051504, authentication then works correctly.



Reproducible: Always

Steps to Reproduce:
1. Visit site.
2. User/Password popup box does not appear.
3.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
Keywords: regression
Can you test this again with a current nightly?

There were some build and FTP problems with that build... Comment 14 in bug 380865 says "If you're using the nightly from 2007-05-16-04-trunk, this isn't expected to be fixed, you need to be using a "nightly" from 2007-05-16-07 or later."
(Reporter)

Comment 2

11 years ago
Original failiure was noticed with 2007051608. Also failing with the 2007051704 build.
(Reporter)

Comment 3

11 years ago
This problem could be a duplicate of bug#380961. Based on comments in that bug I retested after creating a new profile. Using the new profile, the prompts for userid and password work as expected. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre ID:2007052108 [cairo]
The fix for 380961 actually landed on the 16th, although the bug isn't clear about that. 2007051704 probably had the fix, although with all the wonkyness with builds over the last week it's hard to tell. 

So, I'll unfortunately have to repeat myself... Are you still seeing this problem with a recent nightly and your old profile? If so, do all the expected usernames and passwords show up in the Preferences -> Show Passwords? Also, try adding a "signon.debug" pref via about:config (set to True), restart the browser, and look for login manager entries in the error console. And failures reported?
(Reporter)

Comment 5

11 years ago
Yes I still see the problem with the 5/25 nightly with my old profile but not with a new profile. I will not be back at my desk until Tuesday so I can't do any testing until then or give you the exact build details. I do know that I see a fault in the error console when I try connecting to the site that isn't working. The observed symptom is rather then the dialog box popping up I see an authentication error page display from the site as if the browser had automatically sent credentials. Is it possible that something else in my old profile is causing the problem? Is there a file(s) that I could move to the new profile to see if either the problem moves or my saved credential information is presented in the pop up? Is there a file(s) I should remove from my old profile (or replace from a new profile) to see if the problem disappears when using my old profile?
(Reporter)

Comment 6

11 years ago
Problem still occurs with the following build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre ID:2007052804 [cairo]

I assume you mean options->security->show passwords. The list is empty however the error console shows errors when I click on show passwords. 

The error console contents from when I clicked on show passwords:

Login Manager: onStateChange accepted: req = chrome://passwordmgr/content/passwordManager.xul, flags = 196612
Login Manager: onStateChange: adding dom listeners
Login Manager: domEventListener: got event DOMContentLoaded
Login Manager: Getting a list of all logins

PwMgr Storage: Reading passwords from C:\Documents and Settings\uuu\Application Data\Mozilla\Firefox\Profiles\bvb4lgem.default/signons2.txt

PwMgr Storage: Failed to decrypt string: ddd.eee.com:80 ()

PwMgr Storage: Writing passwords to C:\Documents and Settings\uuu\Application Data\Mozilla\Firefox\Profiles\bvb4lgem.default/signons2.txt

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 614"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js
Line: 614

Login Manager: Initialization of storage component failed: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 614"  data: no]

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 450

Error: uncaught exception: [Exception... "'[JavaScript Error: "this._storage has no properties" {file: "file:///C:/Program%20Files/Minefield/components/nsLoginManager.js" line: 450}]' when calling method: [nsILoginManager::getAllLogins]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://passwordmgr/content/passwordManager.js :: LoadSignons :: line 43"  data: yes]

error console list when accessing the site requiring

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 613"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js
Line: 613

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre ID:2007052804 [cairo]

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 614"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js
Line: 614

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre ID:2007052804 [cairo]

Login Manager: Checking if logins to aaa.bbb.com:80 can be saved.

PwMgr Storage: Reading passwords from C:\Documents and Settings\uuu\Application Data\Mozilla\Firefox\Profiles\bvb4lgem.default/signons2.txt

PwMgr Storage: Failed to decrypt string: ddd.eee.com:80 ()

PwMgr Storage: Writing passwords to C:\Documents and Settings\uuu\Application Data\Mozilla\Firefox\Profiles\bvb4lgem.default/signons2.txt

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 614"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js
Line: 614

Login Manager: Initialization of storage component failed: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISecretDecoderRing.encryptString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/storage-Legacy.js :: anonymous :: line 614"  data: no]

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Error: this._storage has no properties
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManager.js
Line: 511

Login Manager: onStateChange accepted: req = http://aaa.bbb.com/C15/C4/CPMPD/default.aspx, flags = 196612

Login Manager: onStateChange: adding dom listeners

Login Manager: domEventListener: got event DOMContentLoaded

Comment 7

11 years ago
I just reported #382319. Is that related?

Although, NTLM basically does work here for me - just not when called from a extension. 
(Reporter)

Comment 8

11 years ago
Visiting the site (http://crb-us.hitwise.com/) reported in forum thread http://forums.mozillazine.org/viewtopic.php?t=553066 I see the same errors in the error console as I see on the site I have been having the problem with.
(In reply to comment #6)

> PwMgr Storage: Reading passwords from C:\Documents and Settings\uuu\Application
> Data\Mozilla\Firefox\Profiles\bvb4lgem.default/signons2.txt
> 
> PwMgr Storage: Failed to decrypt string: ddd.eee.com:80 ()

These errors indicate that your signons2.txt file is corrupted. It's trying to decrypt the wrong line, which is probably due to some other entry having too few/many lines. Have you ever edited that file manually? The format can be tricky, and is easy to mess up.

I'd be curious to see what the contents of your signons2.txt file are... You can obscure hostnames and the encrypted entries, as I don't need the exact values. If you don't mind, email or attach here.

This is probably a duplicate of bug 381787, and doesn't really have anything to do with NTLM Auth.
(Reporter)

Comment 10

11 years ago
I have never tried editing this file. The profile contained signons2.txt, signons2-1.txt and signons2-2.txt. I will zip and email these files to you.

I went back to an older profile that had a signons2.txt file and replaced the one in the failing profile (removing the two other files). This did not change the lack of a authentication prompt.

I also tried removing the file altogether. This had very strange results. The prompt for user/password appears. If I don't check use password manager, I can signon successfully. If if do check use password manager, the logon fails.
(Reporter)

Comment 11

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070530 Minefield/3.0a5pre ID:2007053004 [cairo]

This is a new problem.

I created a new profile for testing.
First access to the web page causes the credentials dialog box to pop up. If I enter user/password and do NOT check use password manager, the logon works.

Repeat test (including creating a new profile). This time use password manager is checked. Logon fails and the error console shows the following:

Error: [Exception... "'Can't add a login without a httpRealm or formSubmitURL.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/nsLoginManagerPrompter.js :: anonymous :: line 213"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManagerPrompter.js
Line: 213

Error: [Exception... "'Can't add a login without a httpRealm or formSubmitURL.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/nsLoginManagerPrompter.js :: anonymous :: line 213"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/nsLoginManagerPrompter.js
Line: 213
(In reply to comment #11)

> Error: [Exception... "'Can't add a login without a httpRealm or formSubmitURL.'
> when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e

This error has been fixed as a result of the recent landing of bug 396316.

(In reply to comment #10)
> I have never tried editing this file. The profile contained signons2.txt,
> signons2-1.txt and signons2-2.txt. I will zip and email these files to you.

Hmm, I remember getting these and checking them, but I don't seem to have commented in this bug again. :( As far as I can recall, the problem was a corrupted file as noted in comment #9. There's no real fix for that, other than to quit firefox, delete signons*.txt, and then restart.

I'm assuming these two issues were causing the issues described in the rather convoluted history of this bug. I think the best thing to do now is close this bug, and if you're still able to reproduce problems with a clean profile then open a new bug for a specific problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: NTLM Authentication Fails - Regression → Multiple problems: corrupted file, empty HTTP realm, NTLM Authentication
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.